I need to completely and definitively get rid of the Immersive Reader's interruptions in Edge

Copper Contributor

There are numerous 'solutions' all over the internet saying to just hit the F9 key or click the icon in the address bar, but when I do either of those, it goes back to the immersive reader less than half a minute later, causing me to have to reload the page and find where I was with each change between immersive reader and not immersive reader.
I've also disabled everything in edge://flags with 'immersive reader' in the title, yet it still comes back.  Those changes in Flags have not changed when it comes back, so my selections are definitely sticking.
Chrome doesn't change the way my pages are displayed and reload them every 30 seconds, why can't I make Edge do that?
 Can't believe such an intrusive function doesn't have an easy to find toggle somewhere to disable it.  This is far and away the most frustrating 'feature' since Clippy...

1 Reply
Hello Matt,
I agree with you completely!
I have searched a lot about that Immersive Reader. Yes, it can be useful. But only when i want it. Not all the time. I know i can use F9 to enter or exit from it. But it activates itself automatically, on every web site.

It is an accessibility feature. Should we disable all accessibility features, from Edge and/or from our computer, to make sure that Immersive Reader won't activates by itself? It would be sad to do such a radical solution.

I think Accessibility functions are a good thing, but only when we need them. It should not be imposing all the time. It should be activated only "on demand".

So, like you, i search how to make it disable always. And then, i would activate it with F9, only when i need it. But i didn't find how to do that. If someone knows, please, answer here!
;)
Isa