SOLVED

HKEY_CURRENT_USER\Software\Policies\Microsoft\Edge\URLWhitelist not respected

%3CLINGO-SUB%20id%3D%22lingo-sub-1113880%22%20slang%3D%22en-US%22%3EHKEY_CURRENT_USER%5CSoftware%5CPolicies%5CMicrosoft%5CEdge%5CURLWhitelist%20not%20respected%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1113880%22%20slang%3D%22en-US%22%3E%3CP%3EOn%20Chrome%20you%20can%20set%20URLWhitelist%20in%20the%20registry%20at%20the%20following%20(or%20HKLM)%3A%3C%2FP%3E%3CP%3EHKEY_CURRENT_USER%5CSoftware%5CPolicies%5CGoogle%5CChrome%5CURLWhitelist%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20would%20presume%20the%20equivalent%20location%20for%20Edge%20is%3A%3C%2FP%3E%3CP%3EHKEY_CURRENT_USER%5CSoftware%5CPolicies%5CMicrosoft%5CEdge%5CURLWhitelist%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20adding%20String%20Values%20under%20the%20key%20has%20no%20impact%20on%20Edge%20but%20works%20correctly%20on%20Chrome.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20running%20Edge%20Stable.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1127897%22%20slang%3D%22en-US%22%3ERe%3A%20HKEY_CURRENT_USER%5CSoftware%5CPolicies%5CMicrosoft%5CEdge%5CURLWhitelist%20not%20respected%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1127897%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F316234%22%20target%3D%22_blank%22%3E%40CodeDJ%3C%2FA%3E%26nbsp%3Bthanks%20for%20the%20question.%20I%20hope%20this%20helps%20explain%20it%20a%20bit%20for%20you.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ETL%3BDR%3B%20this%20is%20called%20an%20%22allow%20list%22%20not%20a%20%22white%20list%22%20in%20Microsoft%20products%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fmicrosoft-edge-policies%23urlallowlist%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fmicrosoft-edge-policies%23urlallowlist%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E-John%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1127949%22%20slang%3D%22en-US%22%3ERe%3A%20HKEY_CURRENT_USER%5CSoftware%5CPolicies%5CMicrosoft%5CEdge%5CURLWhitelist%20not%20respected%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1127949%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F318459%22%20target%3D%22_blank%22%3E%40johnjansen%3C%2FA%3E%26nbsp%3Bawesome!%20that%20works%20-%20thank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

On Chrome you can set URLWhitelist in the registry at the following (or HKLM):

HKEY_CURRENT_USER\Software\Policies\Google\Chrome\URLWhitelist

 

I would presume the equivalent location for Edge is:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Edge\URLWhitelist

 

However, adding String Values under the key has no impact on Edge but works correctly on Chrome.

 

I am running Edge Stable.

2 Replies
Best Response confirmed by CodeDJ (Contributor)
Solution

@CodeDJ thanks for the question. I hope this helps explain it a bit for you. 

 

TL;DR; this is called an "allow list" not a "white list" in Microsoft products:

 

https://docs.microsoft.com/en-us/deployedge/microsoft-edge-policies#urlallowlist

 

-John