hand-tracking feature on edge with Hololens2 not working

Copper Contributor

Hi all, After updating to version 110, I'm trying to use hand-tracking feature on webXR with Hololens2. But with the message "Unrecognized feature requested: hand-tracking" I couldn't enter XR context. Does any one knows this issue and how to solve it? on Edge version 111 I can't even enter XRSession.

4 Replies

I can confirm this is still a problem as of March 29th. Cannot get hand tracking to work at all in the Hololens 2, version 110.

I'm also facing the same issue.

In the case of Babylon.js:
I couldn't switch to immersive mode. However, with the Canary version, I was able to switch to immersive mode. Additionally, hand interaction seems to be working at glance. But the hand model doesn't appear. I suspect that it might be working as controller tracking instead of hand tracking.

In the case of A-Frame:
I tested the behavior using the demo below. First, the AR button in the bottom right corner of the screen no longer appears. By tapping the VR button, I can switch to immersive mode, but hand tracking still doesn't work.
WebXr Incubators enabled on Edge for Hololens 2, but it doesn't work very well, for example immersive-AR and Image Image Tracking don't activate giving error! I use babylonJs quietly on Google Chrome for android with excellent results, but the impossibility of being able to install google chrome on Hololens and being able to use only Edge with these problems makes the work useless and greatly limits the possibility of developing WebXr applications that I find really useful and with a bright future.
I hope that microsoft will solve the problem with the next updates, I also tried to contact support but for the moment they have not been able to provide me with solutions for the problem, maybe someone on the blog has some ideas?