SOLVED

GPG check FAILED in limux (RPM)

Copper Contributor

I've upgrade with dnf and have this error, in the most recient version of microsoft-edge-stable

 

Upgrading:
microsoft-edge-stable x86_64 112.0.1722.39-1 microsoft-edge 137 M

 

_____________________________________________________________

 

Downloading Packages:
microsoft-edge-stable-112.0.1722.39-1.x86_64.rpm 36 MB/s | 137 MB 00:03
----------------------------------------------------------------------------------------
Total 36 MB/s | 137 MB 00:03
Problem opening package microsoft-edge-stable-112.0.1722.39-1.x86_64.rpm
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED

 

_________________________________________________________________________

 

File: /etc/yum.repos.d/microsoft-edge.repo

 

1 │ [microsoft-edge]
2 │ name=microsoft-edge
3 │ baseurl=https://packages.microsoft.com/yumrepos/edge/
4 │ enabled=1
5 │ gpgcheck=1
6 │ gpgkey=https://packages.microsoft.com/keys/microsoft.asc

 

Regards.,

2 Replies
best response confirmed by louzaoh (Copper Contributor)
Solution
thx was fixed today, upgrade was posible, very quickly responde from your part

Regards.,
Issue has reappeared with 115.0.1901.183:
`Error: Transaction test error:
package microsoft-edge-stable-115.0.1901.183-1.x86_64 does not verify: RSA signature: BAD (header tag 1002: invalid OpenPGP signature: Parsing an OpenPGP packet:
Failed to parse Signature Packet
because: Signature appears to be created by a non-conformant OpenPGP implementation, see <https://github.com/rpm-software-management/rpm/issues/2351>.
because: Malformed MPI: leading bit is not set: expected bit 1 to be set in 0 (0))`
1 best response

Accepted Solutions
best response confirmed by louzaoh (Copper Contributor)
Solution
thx was fixed today, upgrade was posible, very quickly responde from your part

Regards.,

View solution in original post