Flickering / brightness changes when hovering mouse over parts in browser window.

Copper Contributor



Don't know if I've come to the right place to ask/report this, but:

In Edge (and Chrome) I have some annoying flickering issues lately. I'm running Edge in dark-mode and in a window (not fullscreen). To reproduce I'm opening a new tab (only search bar on page visible) with the dark background. When hovering the mouse over the favorites bar, address bar, clicking outside the Edge window (on desktop) or make some other movements, the Edge screen flickers a bit (not continuously but on certain moments). Like it's gamma/brightness changes randomly on certain moments. I also had a Teams video meeting on top of the Edge window (so Teams had a smaller window) and that made the visible bottom part of the Edge window flicker a lot. Its really disturbing. I've updated graphics drivers and even monitor firmware and turned of local-dimming, but nothing helps. 


It is only happening in Chrome and Edge. Not in a dark File Explorer window or Firefox. 


However, I discovered the issue is not present when turning off "Use Hardware Acceleration When Available" or in edge://flags setting "Choose ANGLE graphics backend" to "D3D9". 


I really hope this can be fixed (unless it's an Intel GPU bug) because it's extremely annoying. Or maybe I should buy a discrete GPU and hope that fixes it. 





My config: 

i7-9700k (using onboard GPU only)


LG 32UL950 monitor (4k @60Hz using Displayport)

Edge version: 86.0.622.69

Windows version: 10 Pro 20H2

Intel GPU Driver version






4 Replies

@Sandervb Same problem here.... Only in Chrome though. Edge is fine.

Same here with a dedicated RTX 3070 . Happend somewhere between getting the new GPU and some Chrome update. Same in all Chromium browsers. Chrome, Edge, Brave, ... Gets worse if you run a game with "frameless window" mode behind it.

@Felix8same here, 3060Ti but also with a 6900XT. I am using Firefox now which has no flicker issues.
But for me it happened as well when changing graphic cards or it was a chrome update just when I switched.

I had the same issue, I fixed my issues by turning Night light setting off. you find it in your display settings, or just search Night Light in your windows search bar,