[FIXED] Problem: Can't open unsafe ports on Edge insider

%3CLINGO-SUB%20id%3D%22lingo-sub-868342%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-868342%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThis%20command%20line%20works%20properly%20for%20me%20in%20Edge%20Canary%2079.0.278.%20Please%20confirm%20that%20you've%20closed%20all%20msedge.exe%20instances%20(using%20task%20manager%20to%20ensure%20there%20aren't%20any%20hidden%20processes%20lingering)%20before%20starting%20a%20new%20one%20using%20this%20command%20line%20argument.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-869126%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-869126%22%20slang%3D%22en-US%22%3EYes%2C%20I%20think%20the%20problem%20was%20solved%20in%20Edge%20insider%2079.%20now%20I'm%20testing%20it%20on%20version%3CBR%20%2F%3EVersion%2079.0.280.0%20(Official%20build)%20canary%20(64-bit)%3CBR%20%2F%3Eand%20it's%20working%20fine.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-860884%22%20slang%3D%22en-US%22%3E%5BFIXED%5D%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860884%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSTRONG%3EUPDATE%3A%20Fixed%20in%20Edge%20insider%26nbsp%3BVersion%2079.0.280.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20need%20to%20open%20a%20custom%20port%20for%20WAC.%20I%20can%20do%20that%20with%20Google%20Chrome%20Canary%2079%20by%20adding%20this%20to%20the%20shortcut%20target%3A%20%22--explicitly-allowed-ports%3D6666%22%20and%20it%20loads%20the%20WAC%20console%20just%20fine.%3C%2FP%3E%3CP%3Ebut%20when%20I%20do%20the%20same%20for%20Edge%20insider%20Canary%2C%20it%20won't%20work%20and%20still%20gives%20me%20the%20unsafe%20port%20error.%3C%2FP%3E%3CP%3E%3CSPAN%3EEdge%20Insider%20Version%2078.0.277.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EWindows%2010%20latest%20ver%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EWAC%201909%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20987px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132323iAA618E939441291E%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-09-18%20160508.png%22%20title%3D%22Annotation%202019-09-18%20160508.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-860884%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Eproblem%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1205589%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1205589%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3Byesterday%20I%20made%20a%20batch%20file%3A%3C%2FP%3E%3CP%3E%22C%3A%5CProgram%20Files%20(x86)%5CMicrosoft%5CEdge%5CApplication%5Cmsedge.exe%22%20-explicitly-allowed-ports%3D6666%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2F%22%20target%3D%22_blank%22%3Ehttp%3A%2F%2F%3CREDACTED%3E%3A6666%2F%3C%2FREDACTED%3E%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20worked%20yesterday%2C%20today%20it%20gives%20unsafe%20port%20error.%3C%2FP%3E%3CP%3EThoughts%3F%3C%2FP%3E%3CP%3E%3CSPAN%3EVersion%2080.0.361.62%20(Official%20build)%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2445327%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2445327%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F572822%22%20target%3D%22_blank%22%3E%40eric79xxl%3C%2FA%3E%26nbsp%3BAfter%20updating%20to%20Win10%20Version%201909%20%2F%20Edge%26nbsp%3B%3CSPAN%3EVersion%2091.0.864.48%20I%20cannot%20reach%20an%20https%20website%20on%20port%2010080%20anymore.%26nbsp%3B%20Edge%20shows%20error%26nbsp%3BERR_UNSAFE_PORT.%20I%20tried%20to%20start%20Edge%20with%20parameter%26nbsp%3B--explicitly-allowed-ports%3D10080%20but%20no%20success.%20Thanks%20for%20your%20support!%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2445337%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2445337%22%20slang%3D%22en-US%22%3EI%20was%20never%20able%20to%20get%20it%20to%20work.%20I%20ended%20up%20having%20to%20use%20a%20different%20browser%2C%20but%20eventually%20ditched%20the%20app%20that%20required%20that%20port.%3CBR%20%2F%3E%3CBR%20%2F%3EAlso%2C%20you%20should%20be%20updating%20to%20at%20least%20version%202004%2C%20if%20not%2020H2.%20Version%201909%20is%20out%20of%20support.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2445370%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2445370%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F460962%22%20target%3D%22_blank%22%3E%40Eric79x%3C%2FA%3E%26nbsp%3BHi%20Eric%2C%20I%20would%20like%20to%20update%20Win10%20to%20the%20latest%20version%2C%20but%20unfortunately%20it's%20managed%20by%20our%20not%20very%20up-to-date%20IT%20workplace%20team.%20I%20got%20my%20outdated%201909%20last%20Friday%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2F%40FE3C8A5543DEF164D4C09E9B7F45E1A4%2Fimages%2Femoticons%2Ffacepalm_40x40.gif%22%20alt%3D%22%3Afacepalm%3A%22%20title%3D%22%3Afacepalm%3A%22%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2445699%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2445699%22%20slang%3D%22en-US%22%3EFor%20clarity%2C%20the%20command%20line%20above%20doesn't%20work%20because%20you%20need%20to%20pass%20--explicitly-allowed-ports%20with%20two%20leading%20dashes.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2445702%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%3A%20Can't%20open%20unsafe%20ports%20on%20Edge%20insider%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2445702%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20command%20line%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSTRONG%3Emsedge.exe%20--explicitly-allowed-ports%3D10080%20%3CA%20href%3D%22http%3A%2F%2Fexample.com%3A10080%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fexample.com%3A10080%3C%2FA%3E%3C%2FSTRONG%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E...still%20works%20properly%20as%20of%20Edge%2093.%20Keep%20in%20mind%2C%20however%2C%20that%20command%20lines%20only%20take%20effect%20when%20the%20browser%20is%20started%20from%20scratch.%20If%20there's%20an%20msedge.exe%20instance%20already%20running%20(even%20a%20hidden%20one%20created%20by%20the%20%22Startup%20Boost%22%20feature%2C%20the%20command%20line%20will%20be%20ignored.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou%20can%20visit%20%3CSTRONG%3Eedge%3A%2F%2Fversion%2F%26nbsp%3B%3C%2FSTRONG%3Eto%20see%20the%20command-line%20currently%20in%20use%20by%20the%20active%20browser.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Honored Contributor

UPDATE: Fixed in Edge insider Version 79.0.280.0 (Official build) canary (64-bit)

 

 

I need to open a custom port for WAC. I can do that with Google Chrome Canary 79 by adding this to the shortcut target: "--explicitly-allowed-ports=6666" and it loads the WAC console just fine.

but when I do the same for Edge insider Canary, it won't work and still gives me the unsafe port error.

Edge Insider Version 78.0.277.0 (Official build) canary (64-bit)

Windows 10 latest ver

WAC 1909

 

Annotation 2019-09-18 160508.png

 

8 Replies

@HotCakeX This command line works properly for me in Edge Canary 79.0.278. Please confirm that you've closed all msedge.exe instances (using task manager to ensure there aren't any hidden processes lingering) before starting a new one using this command line argument.

Yes, I think the problem was solved in Edge insider 79. now I'm testing it on version
Version 79.0.280.0 (Official build) canary (64-bit)
and it's working fine.

@ericlaw yesterday I made a batch file:

"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" -explicitly-allowed-ports=6666 http://<redacted>:6666/

 

It worked yesterday, today it gives unsafe port error.

Thoughts?

Version 80.0.361.62 (Official build) (64-bit)

@eric79xxl After updating to Win10 Version 1909 / Edge Version 91.0.864.48 I cannot reach an https website on port 10080 anymore.  Edge shows error ERR_UNSAFE_PORT. I tried to start Edge with parameter --explicitly-allowed-ports=10080 but no success. Thanks for your support!

I was never able to get it to work. I ended up having to use a different browser, but eventually ditched the app that required that port.

Also, you should be updating to at least version 2004, if not 20H2. Version 1909 is out of support.

@Eric79x Hi Eric, I would like to update Win10 to the latest version, but unfortunately it's managed by our not very up-to-date IT workplace team. I got my outdated 1909 last Friday :facepalm:

For clarity, the command line above doesn't work because you need to pass --explicitly-allowed-ports with two leading dashes.

The command line

 

msedge.exe --explicitly-allowed-ports=10080 http://example.com:10080

 

...still works properly as of Edge 93. Keep in mind, however, that command lines only take effect when the browser is started from scratch. If there's an msedge.exe instance already running (even a hidden one created by the "Startup Boost" feature, the command line will be ignored.

 

You can visit edge://version/ to see the command-line currently in use by the active browser.