Error Installing/updating New Microsoft Edge

%3CLINGO-SUB%20id%3D%22lingo-sub-1389767%22%20slang%3D%22en-US%22%3EError%20Installing%2Fupdating%20New%20Microsoft%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1389767%22%20slang%3D%22en-US%22%3E%3CP%3EI%20was%20trying%20to%20use%20google%20meet%20and%20it%20said%20that%20i%20need%20to%20update%20my%20Microsoft%20Edge%20browser.%20I%20downloaded%20the%20new%20update%20and%20installed%20it%20but%20it%20showed%20the%20error%3A%20%22Failed%20to%20cache%20the%20downloaded%20installer%200x8007......%22%20i%20don't%20remember%20the%20rest.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20searched%20up%20the%20microsoft%20support%20page%20only%20to%20get%20more%20confused%20so%20i%20tried%20clearing%20my%20temporary%20files%20and%20tried%20installing%20it%20again%20and%20it%20is%20still%20showing%20error%20but%20a%20different%20one%20%22There%20was%20a%20problem%20downloading%20the%20required%20files.%20Error%3A%200x80070070%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20any%20way%20to%20fix%20this%3F%20Is%20my%20browser%20too%20outdated%3F%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20Microsoft%20Edge%20version%2025.10586.672.0%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20would%20be%20great%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1389767%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ecache%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDownload%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EEdge%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EError%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EInstallation%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EUpdate%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1389803%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Installing%2Fupdating%20New%20Microsoft%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1389803%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F668097%22%20target%3D%22_blank%22%3E%40DaizT1%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%20there%2C%20welcome%20to%20the%20Microsoft%20Tech%20Community.%3C%2FP%3E%3CP%3EIf%20you%20were%20using%20the%20online%20installer%20of%20Microsoft%20Edge%20Chromium%2C%20then%20I%20would%20ask%20you%20to%20give%20a%20try%20to%20offline%20MSI%20installer.%20You%20can%20download%20it%20by%20clicking%20the%20link%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fedge%2Fbusiness%2Fdownload%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehere.%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20hope%20that%20your%20Microsoft%20Edge%20Chromium%20experience%20will%20be%20great.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

I was trying to use google meet and it said that i need to update my Microsoft Edge browser. I downloaded the new update and installed it but it showed the error: "Failed to cache the downloaded installer 0x8007......" i don't remember the rest.

 

I searched up the microsoft support page only to get more confused so i tried clearing my temporary files and tried installing it again and it is still showing error but a different one "There was a problem downloading the required files. Error: 0x80070070"

 

Is there any way to fix this? Is my browser too outdated? 

I have the Microsoft Edge version 25.10586.672.0

 

Any help would be great

 

1 Reply
Highlighted

@DaizT1 

Hello there, welcome to the Microsoft Tech Community.

If you were using the online installer of Microsoft Edge Chromium, then I would ask you to give a try to offline MSI installer. You can download it by clicking the link here. 

I hope that your Microsoft Edge Chromium experience will be great.