ERR_CERT_COMMON_NAME_INVALID

%3CLINGO-SUB%20id%3D%22lingo-sub-739957%22%20slang%3D%22en-US%22%3EERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-739957%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20of%20this%20post%2C%20I%20am%20running%20Microsoft%20Edge%20DEV%20Version%2077.0.197.1%20(Official%20build)%20dev%20(64-bit)%20on%20Windows%207%2C%20configured%20as%20my%20default%20browser.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20server%20running%20running%20McAfee%20ePolicy%20Orchestrator%20that%20is%20currently%20configured%20to%20use%20a%20self-signed%20certificate%20that%20has%20a%20CA%20name%20like%26nbsp%3BOrion_CA_%3CHOSTNAME%3E%20and%20a%20website%20certificate%20issued%20by%20this%20CA%20to%20%3CHOSTNAME%3E.%3C%2FHOSTNAME%3E%3C%2FHOSTNAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENote%20%3CHOSTNAME%3E%20is%20not%20a%20FQDN%2C%20just%20a%20short%20host%20name.%3C%2FHOSTNAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20ePO%20website%20is%20accessed%20with%20a%20URL%20like%3A%20https%3A%2F%2F%3CHOSTNAME%3E%3A8443%2F%3C%2FHOSTNAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20my%20local%20machine%20certificate%20store%20configured%20with%20the%20McAfee%20CA%20so%20IE11%20trusts%20the%20CA%20and%20associated%20ePO%20certificate%20and%20connects%20to%20the%20website%20without%20any%20certificate%20errors%20or%20warnings.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20using%20Edge%20DEV%20I%20get%20the%26nbsp%3B%3CSTRONG%3EYour%20connection%20isn't%20private%3C%2FSTRONG%3E%20warning%20with%20the%20error%20shown%20as%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENET%3A%3AERR_CERT_COMMON_NAME_INVALID%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20aware%20of%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc6125%23section-5.7.3.1%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc6125%23section-5.7.3.1%3C%2FA%3E%26nbsp%3Band%20Google%20Chrome's%20deprecation%20of%20the%20use%20of%20a%20Common%20Name%20field%20in%20an%20SSL%20certificate.%20This%20self-signed%20ePO%20certificate%20does%20not%20have%20a%20SAN%20configured.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20found%20a%20Symantec%20reference%20for%20Google%20Chrome%20that%20discusses%20adding%26nbsp%3BEnableCommonNameFallbackForLocalAnchors%20to%26nbsp%3BHKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CGoogle%5CChrome%20however%2C%20there%20is%20no%20corresponding%26nbsp%3BHKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CMicrosoft%5CEdge%20key%20on%20my%20machine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.symantec.com%2Fus%2Fen%2Farticle.TECH240507.html%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.symantec.com%2Fus%2Fen%2Farticle.TECH240507.html%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20realize%20I%20can%20fix%20this%20by%20generating%20a%20more%20conformant%20certificate%20but%20should%20Chromium%20Edge%20also%20support%20this%20registry%20work-around%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECreating%20a%20key%26nbsp%3BHKEY_LOCAL_MACHINE%5CSOFTWARE%5CPolicies%5CMicrosoft%5C%3CSTRONG%3EEdge%3C%2FSTRONG%3E%26nbsp%3Band%20adding%20the%20DWORD%26nbsp%3B%3CSTRONG%3EEnableCommonNameFallbackForLocalAnchors%3C%2FSTRONG%3E%26nbsp%3Bwith%20a%20value%20set%20to%201%20did%20not%20change%20the%20behavior%20in%20my%20Edge%20DEV%20installation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20get%20to%20the%20ePO%20website%20with%20Edge%20DEV%20by%20clicking%20the%20Advanced%20button%20on%20the%20warning%20page%20which%20does%20indeed%20tell%20me%20the%20problem%20is%20a%20missing%20SAN%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20server%20couldn't%20prove%20that%20it's%20%3CHOSTNAME%3E%3B%20its%20security%20certificate%20does%20not%20specify%20Subject%20Alternative%20Names.%20This%20may%20be%20caused%20by%20a%20misconfiguration%20or%20an%20attacker%20intercepting%20your%20connection.%3C%2FHOSTNAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EClicking%20the%20link%3A%26nbsp%3B%3CEM%3EContinue%20to%20%3CHOSTNAME%3E%20(unsafe)%3C%2FHOSTNAME%3E%3C%2FEM%3E%20does%20allow%20me%20to%20get%20to%20the%20website%20but%20it%20shows%20the%20%3CSTRONG%3ENot%20Secure%3C%2FSTRONG%3E%20warning%20and%20the%20lined-through%20https%20protocol%20string%20in%20the%20URL.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-Eric%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-740185%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-740185%22%20slang%3D%22en-US%22%3EThe%20policy%20EnableCommonNameFallbackForLocalAnchors%20was%20removed%20in%20Chrome%2066%20and%20thus%20never%20supported%20in%20Microsoft%20Edge%20Insider.%20You'll%20need%20to%20update%20the%20certificate%20generator%20such%20that%20it%20generates%20certificates%20containing%20SubjectAltNames.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fcs.chromium.org%2Fchromium%2Fsrc%2Fchrome%2Ftest%2Fdata%2Fpolicy%2Fpolicy_test_cases.json%3Fl%3D871%26amp%3Brcl%3D8fc422f8b81ebe66b35918c426c2b46cfba96e24%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fcs.chromium.org%2Fchromium%2Fsrc%2Fchrome%2Ftest%2Fdata%2Fpolicy%2Fpolicy_test_cases.json%3Fl%3D871%26amp%3Brcl%3D8fc422f8b81ebe66b35918c426c2b46cfba96e24%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1214862%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1214862%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3BThe%20Edge%20DEV%20browser%26nbsp%3B%3CSPAN%3Eversion%2082.0.439.1%20(Official%20build)%20dev%20(64-bit)%20is%20now%20frequently%20throwing%20this%20error%20on%20standard%20public%20sites%20like%3A%20youtube.com%2C%20facebook.com%2C%20and%20wellsfargo.com.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EIt's%20seems%20more%20likely%20that%20the%20browser%20is%20not%20handling%20these%20sites%20correctly%20rather%20than%20all%20of%20these%20sites%20are%20suddenly%20having%20issues%20with%20their%20SSL%20certs.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CTODD%3E%3C%2FTODD%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1214865%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1214865%22%20slang%3D%22en-US%22%3EHowdy%2C%20Todd.%20The%20most%20likely%20explanation%20here%20is%20that%20you're%20behind%20a%20buggy%20network%20appliance%2C%20perhaps%20a%20ZScaler.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fyour-connection-isn-t-private-zscaler%2Fm-p%2F1198911%2Fhighlight%2Ftrue%23M25369%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fyour-connection-isn-t-private-zscaler%2Fm-p%2F1198911%2Fhighlight%2Ftrue%23M25369%3C%2FA%3E%20for%20more%20information%2C%20including%20a%20workaround.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1214915%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1214915%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3BI'm%20actually%20at%20home%20accessing%20the%20Internet%20via%20a%20Century%20Link%20C2100Z%20appliance.%20While%20Century%20Link%20may%20have%20a%20ZScaler%20somewhere%20up%20the%20line%2C%20I%20won't%20have%20any%20access%20to%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThat%20said%2C%20if%20I%20switch%20to%20my%20other%20laptop%20(which%20is%20still%20using%20the%20native%20Windows%2010%20Edge%20browser)%20and%20browse%20these%20sites%20from%20the%20same%20network%2C%20I%20have%20no%20issues.%20So%20again%2C%20it%20seems%20that%20something%20is%20fishy%20with%20the%20browser%20(or%20at%20least%20the%20Windows%2010%20laptop%20that%20the%20Edge%20Dev%20browser%20is%20running%20on).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CTODD%3E%3C%2FTODD%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1214919%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1214919%22%20slang%3D%22en-US%22%3EI%20should%20mention%2C%20I%20did%20try%20the%20workaround.%20But%20running%20the%20following%20command%20does%20not%20fix%20the%20issue%3A%3CBR%20%2F%3Emsedge.exe%20--disable-features%3DPostQuantumCECPQ2%3CBR%20%2F%3E%3CBR%20%2F%3E%3CTODD%3E%3C%2FTODD%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1218538%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1218538%22%20slang%3D%22en-US%22%3EHi%2C%20Todd--%20The%20other%20explanation%20is%20that%20you're%20behind%20some%20sort%20of%20misconfigured%20device%20or%20there's%20malware%20causing%20the%20issue.%20%3CBR%20%2F%3E%3CBR%20%2F%3ESharing%20the%20full%20certificate%20info%20of%20an%20incorrect%20certificate%20(see%20%3CA%20href%3D%22https%3A%2F%2Ftextslashplain.com%2F2017%2F03%2F30%2Fget-help-with-https-problems%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftextslashplain.com%2F2017%2F03%2F30%2Fget-help-with-https-problems%2F%3C%2FA%3E%20)%20or%20a%20Network%20Log%20(%3CA%20href%3D%22https%3A%2F%2Ftextslashplain.com%2F2020%2F01%2F17%2Fcapture-network-logs-from-edge-and-chrome%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftextslashplain.com%2F2020%2F01%2F17%2Fcapture-network-logs-from-edge-and-chrome%2F%3C%2FA%3E)%20would%20allow%20me%20to%20tell%20you%20what%20specifically%20is%20happening.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1219085%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1219085%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3BHi!%20The%20same%20problem%20is%20happening%20to%20me%2C%20and%26nbsp%3B%3CSTRONG%3Eonly%3C%2FSTRONG%3E%20in%20a%20specific%20situation%3A%20when%20accessing%20Twitter%20from%20an%20email%20I%20got%20on%20my%20Gmail%20saying%20I%20have%20a%20new%20Direct%20Message.%20If%20I%20click%20on%20the%20link%20from%20there%2C%20this%20happens.%20If%20I%20access%20Twitter%20from%20any%20other%20means%2C%20it%20works%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20certificate%20information%20and%20the%20network%20log%20are%20in%20attachment%2C%20in%20the%20same%20ZIP%20file.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1220282%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1220282%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F561056%22%20target%3D%22_blank%22%3E%40RobertoSAG%3C%2FA%3E%26nbsp%3BThe%20immediate%20problem%20is%20that%20the%20certificate%20(thumbprint%26nbsp%3Bd4b95942dea3f885dc782634cbcc0c8cabe82b4c)%20being%20presented%20for%20%22%3CA%20href%3D%22http%3A%2F%2Fwww.twitter.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ewww.twitter.com%3C%2FA%3E%22%20does%20not%20contain%20%22%3CA%20href%3D%22http%3A%2F%2Fwww.twitter.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ewww.twitter.com%3C%2FA%3E%22%2C%20only%20%22twitter.com%22.%20The%20live%20certificate%20I%20see%20for%20Twitter%20when%20navigating%20to%20it%20from%20Texas%2C%20USA%20includes%20both.%20When%20navigating%20to%20Twitter%20from%20Brazil%2C%20I%20get%20the%20certificate%20lacking%20the%20%22www.%22%20I%20%3CA%20href%3D%22https%3A%2F%2Ftwitter.com%2Fericlaw%2Fstatus%2F1237413065441804290%22%20target%3D%22_self%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ereached%20out%20to%20Twitter%20Engineering%3C%2FA%3E.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIt%20appears%20that%20either%20Twitter%20mis-issued%20this%20certificate%20(it%20should%20have%20included%20the%20%22www.%22%20prefix)%2C%20or%20misconfigured%20their%20servers%20such%20that%20a%20server%20which%20was%20supposed%20to%20use%20a%20%22www.%22%20certificate%20instead%20chose%20the%20certificate%20that%20omitted%20the%20%22www.%22%20entry.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftransparencyreport.google.com%2Fhttps%2Fcertificates%2Fg0T85Ehr432jmCfz2vNRWCTBC6toFh9xDoKwc9Jzrl8%253D%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftransparencyreport.google.com%2Fhttps%2Fcertificates%2Fg0T85Ehr432jmCfz2vNRWCTBC6toFh9xDoKwc9Jzrl8%253D%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1220831%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1220831%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3BThank%20you!%20I'm%20not%20a%20web%20developer%2C%20but%20is%20there%20anything%20I%20can%20do%20to%20report%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1220922%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1220922%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20Twitter%20team%20reports%20that%20they're%20working%20on%20it%3B%20see%20the%20%22reached%20out%20to%22%20link%20above.%20(I'm%20presuming%20that%20you're%20located%20somewhere%20near%20Brazil%3B%20if%20not%2C%20it%20might%20be%20helpful%20for%20you%20to%20share%20a%20bit%20more%20info%20so%20I%20can%20make%20sure%20that%20they%20fix%20this%20everywhere%20that%20is%20impacted).%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1220972%22%20slang%3D%22en-US%22%3ERe%3A%20ERR_CERT_COMMON_NAME_INVALID%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1220972%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F317619%22%20target%3D%22_blank%22%3E%40ericlaw%3C%2FA%3E%26nbsp%3BYeah%2C%20I'm%20in%20Brazil%2C%20and%20that%20makes%20sense.%20Thank%20you%20for%20the%20assistance!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

@ericlaw 

 

As of this post, I am running Microsoft Edge DEV Version 77.0.197.1 (Official build) dev (64-bit) on Windows 7, configured as my default browser.

 

I have a server running running McAfee ePolicy Orchestrator that is currently configured to use a self-signed certificate that has a CA name like Orion_CA_<hostname> and a website certificate issued by this CA to <hostname>.

 

Note <hostname> is not a FQDN, just a short host name.

 

The ePO website is accessed with a URL like: https://<hostname>:8443/

 

I have my local machine certificate store configured with the McAfee CA so IE11 trusts the CA and associated ePO certificate and connects to the website without any certificate errors or warnings.

 

However, using Edge DEV I get the Your connection isn't private warning with the error shown as:

 

NET::ERR_CERT_COMMON_NAME_INVALID

 

I am aware of https://tools.ietf.org/html/rfc6125#section-5.7.3.1 and Google Chrome's deprecation of the use of a Common Name field in an SSL certificate. This self-signed ePO certificate does not have a SAN configured.

 

I found a Symantec reference for Google Chrome that discusses adding EnableCommonNameFallbackForLocalAnchors to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome however, there is no corresponding HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge key on my machine.

 

https://support.symantec.com/us/en/article.TECH240507.html 

 

I realize I can fix this by generating a more conformant certificate but should Chromium Edge also support this registry work-around?

 

Creating a key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge and adding the DWORD EnableCommonNameFallbackForLocalAnchors with a value set to 1 did not change the behavior in my Edge DEV installation.

 

I can get to the ePO website with Edge DEV by clicking the Advanced button on the warning page which does indeed tell me the problem is a missing SAN:

 

This server couldn't prove that it's <hostname>; its security certificate does not specify Subject Alternative Names. This may be caused by a misconfiguration or an attacker intercepting your connection.

 

Clicking the link: Continue to <hostname> (unsafe) does allow me to get to the website but it shows the Not Secure warning and the lined-through https protocol string in the URL.

 

-Eric

11 Replies
Highlighted
The policy EnableCommonNameFallbackForLocalAnchors was removed in Chrome 66 and thus never supported in Microsoft Edge Insider. You'll need to update the certificate generator such that it generates certificates containing SubjectAltNames.

https://cs.chromium.org/chromium/src/chrome/test/data/policy/policy_test_cases.json?l=871&rcl=8fc422...
Highlighted

@ericlaw The Edge DEV browser version 82.0.439.1 (Official build) dev (64-bit) is now frequently throwing this error on standard public sites like: youtube.com, facebook.com, and wellsfargo.com.

 

It's seems more likely that the browser is not handling these sites correctly rather than all of these sites are suddenly having issues with their SSL certs.

 

<Todd />

Highlighted
Howdy, Todd. The most likely explanation here is that you're behind a buggy network appliance, perhaps a ZScaler. Please see https://techcommunity.microsoft.com/t5/discussions/your-connection-isn-t-private-zscaler/m-p/1198911... for more information, including a workaround.
Highlighted

@ericlaw I'm actually at home accessing the Internet via a Century Link C2100Z appliance. While Century Link may have a ZScaler somewhere up the line, I won't have any access to it.

 

That said, if I switch to my other laptop (which is still using the native Windows 10 Edge browser) and browse these sites from the same network, I have no issues. So again, it seems that something is fishy with the browser (or at least the Windows 10 laptop that the Edge Dev browser is running on).

 

<Todd />

Highlighted
I should mention, I did try the workaround. But running the following command does not fix the issue:
msedge.exe --disable-features=PostQuantumCECPQ2

<Todd />
Highlighted
Hi, Todd-- The other explanation is that you're behind some sort of misconfigured device or there's malware causing the issue.

Sharing the full certificate info of an incorrect certificate (see https://textslashplain.com/2017/03/30/get-help-with-https-problems/ ) or a Network Log (https://textslashplain.com/2020/01/17/capture-network-logs-from-edge-and-chrome/) would allow me to tell you what specifically is happening.
Highlighted

@ericlaw Hi! The same problem is happening to me, and only in a specific situation: when accessing Twitter from an email I got on my Gmail saying I have a new Direct Message. If I click on the link from there, this happens. If I access Twitter from any other means, it works fine.

 

The certificate information and the network log are in attachment, in the same ZIP file.

 

 

Highlighted

@RobertoSAG The immediate problem is that the certificate (thumbprint d4b95942dea3f885dc782634cbcc0c8cabe82b4c) being presented for "www.twitter.com" does not contain "www.twitter.com", only "twitter.com". The live certificate I see for Twitter when navigating to it from Texas, USA includes both. When navigating to Twitter from Brazil, I get the certificate lacking the "www." I reached out to Twitter Engineering.

 

It appears that either Twitter mis-issued this certificate (it should have included the "www." prefix), or misconfigured their servers such that a server which was supposed to use a "www." certificate instead chose the certificate that omitted the "www." entry.

 

https://transparencyreport.google.com/https/certificates/g0T85Ehr432jmCfz2vNRWCTBC6toFh9xDoKwc9Jzrl8...

 

 

Highlighted

@ericlaw Thank you! I'm not a web developer, but is there anything I can do to report this?

Highlighted

The Twitter team reports that they're working on it; see the "reached out to" link above. (I'm presuming that you're located somewhere near Brazil; if not, it might be helpful for you to share a bit more info so I can make sure that they fix this everywhere that is impacted).

Highlighted

@ericlaw Yeah, I'm in Brazil, and that makes sense. Thank you for the assistance!