SOLVED
Home

Edge Stuck on Setting Up Sync

%3CLINGO-SUB%20id%3D%22lingo-sub-1099718%22%20slang%3D%22en-US%22%3EEdge%20Stuck%20on%20Setting%20Up%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1099718%22%20slang%3D%22en-US%22%3E%3CP%3EUsing%20%3CSPAN%3EVersion%2081.0.381.0%20(Official%20build)%20dev%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20setup%20sync%20on%20my%20work%20Network%2C%20the%20sync%20just%20stays%20on%20%22Setting%20up%20Sync%22.%20However%2C%20when%20I%20go%20off%20company%20WI-FI%20and%20onto%20cellular%2C%20the%20sync%20works%20fine%20and%20the%20status%20changes%20to%20%22Sync%20is%20on%22.%20Its%20more%20than%20likely%20a%20problem%20with%20the%20company%20firewall.%20The%20IT%20admin%20always%20asks%20which%20port%2Furl%20they%20need%20to%20open.%20What%20needs%20to%20be%20opened%20for%20Edge%20Sync%20to%20work%20properly%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1099718%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFirewall%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESync%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1099844%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Stuck%20on%20Setting%20Up%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1099844%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Etry%20opening%20in%20the%20firewall%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Factivity.windows.com%2Fv1%2Ffeeds%2Fme%2FsyncEntities%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Factivity.windows.com%2Fv1%2Ffeeds%2Fme%2FsyncEntities%2F%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3Ethat's%20the%20server%20URL%20shown%20in%20the%20edge%3A%2F%2Fsync-internals%2F%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1113984%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Stuck%20on%20Setting%20Up%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1113984%22%20slang%3D%22en-US%22%3E%3CP%3EThanks.%20That%20was%20extremely%20helpful.%20Everything%20works%20great%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1114218%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Stuck%20on%20Setting%20Up%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1114218%22%20slang%3D%22en-US%22%3EAwesome%2C%20you're%20welcome%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1148020%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Stuck%20on%20Setting%20Up%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1148020%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20there%3B%20thanks%20for%20the%20reply%20above.%20We%20are%20exhibiting%20the%20same%20behavior%20of%20the%20profile%20being%20stuck%20at%20%22Setting%20Up%20Sync.%22%20I%20do%20not%20see%20any%20activity%20being%20blocked%20for%20this%20pilot%20PC%20in%20our%20Firewall.%20I%20have%20also%20confirmed%20that%20on%20a%20separate%20computer%2C%20completely%20off%20our%20domain%2C%20the%20same%20thing%20is%20happening.%20The%20sign-in%20is%20with%20an%20O365%20account.%20It%20seems%20strange%20that%20it's%20happening%20on%20as%20well%20as%20off%20our%20domain.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20forced%20the%20Sign-In%20requirement%20via%20Group%20Policy%2C%20and%20I%20turned%20it%20off%20in%20case%20there%20was%20something%20wacky%20going%20on%20there%2C%20but%20that%20didn't%20make%20a%20difference%20either.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20anyone%20has%20any%20ideas%2C%20please%20let%20me%20know!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1148037%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Stuck%20on%20Setting%20Up%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1148037%22%20slang%3D%22en-US%22%3EUpdate%3A%20It%20looks%20like%20this%20is%20due%20to%20our%20subscription%20level%20for%20O365%20(we're%20only%20business%20premium).%20This%20is%20kind%20of%20lame.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fmicrosoft-edge-enterprise-sync%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fmicrosoft-edge-enterprise-sync%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1148056%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Stuck%20on%20Setting%20Up%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1148056%22%20slang%3D%22en-US%22%3EGood%20find%2C%3CBR%20%2F%3Ewell%20it%20says%20%22Sync%20has%20a%20dependency%20on%20the%20protection%20service%20offered%20by%20Azure%20Information%20Protection%20(AIP)%20to%20protect%20sync%20data%22%20so%20it%20kinda%20makes%20sense%20to%20require%20it%20for%20sync.%20I%20think%20since%20you%20can't%20sync%20with%20your%20account%2C%20you%20can't%20sign%20in%20either%20because%20what%20would%20be%20the%20point.%3C%2FLINGO-BODY%3E
Highlighted
Jason101
New Contributor

Using Version 81.0.381.0 (Official build) dev (64-bit)

 

When I setup sync on my work Network, the sync just stays on "Setting up Sync". However, when I go off company WI-FI and onto cellular, the sync works fine and the status changes to "Sync is on". Its more than likely a problem with the company firewall. The IT admin always asks which port/url they need to open. What needs to be opened for Edge Sync to work properly?  I tried to watch traffic off my machine, but couldn't make a determination of what URL sync is trying to access.

6 Replies
Highlighted
Solution
Hi,
try opening in the firewall
https://activity.windows.com/v1/feeds/me/syncEntities/

that's the server URL shown in the edge://sync-internals/
Highlighted

Thanks. That was extremely helpful. Everything works great now.

Highlighted
Awesome, you're welcome :)
Highlighted

@HotCakeX 

 

Hi there; thanks for the reply above. We are exhibiting the same behavior of the profile being stuck at "Setting Up Sync." I do not see any activity being blocked for this pilot PC in our Firewall. I have also confirmed that on a separate computer, completely off our domain, the same thing is happening. The sign-in is with an O365 account. It seems strange that it's happening on as well as off our domain.

 

I had forced the Sign-In requirement via Group Policy, and I turned it off in case there was something wacky going on there, but that didn't make a difference either.

 

If anyone has any ideas, please let me know!

Highlighted
Update: It looks like this is due to our subscription level for O365 (we're only business premium). This is kind of lame.

https://docs.microsoft.com/en-us/deployedge/microsoft-edge-enterprise-sync
Highlighted
Good find,
well it says "Sync has a dependency on the protection service offered by Azure Information Protection (AIP) to protect sync data" so it kinda makes sense to require it for sync. I think since you can't sync with your account, you can't sign in either because what would be the point.
Related Conversations
Importer is not working
Stoni1350 in OneDrive for Business on
0 Replies
Sync Page switches not aligned properly.
Codie1280 in Discussions on
2 Replies
[Feature Suggestion] Show update history in Edge
HotCakeX in Discussions on
0 Replies
Beta channel update to 81.0.416.12 is live
HotCakeX in Discussions on
11 Replies
New change: Download settings relocated
HotCakeX in Discussions on
14 Replies