Edge Opening With Different Language

Occasional Contributor

For the last two days, when I open Edge, it opens in Chinese.  I have checked settings, languages, etc and everything says I should be getting English.  I have also checked under languages and there are no check marks in any other languages.  The only thing that has happened in the last two days is an automatic update to Edge.  Any idea how I can get back to English language and English articles on the Edge home page?

14 Replies

Hi  @Samman01

Of course, you can change the settings -> see screenshot:

Zrzut ekranu 2022-03-12 195516.pngZrzut ekranu 2022-03-12 195349.png

 

@Andrzej1 

 

Thank you for trying to help me.  I followed your screen shots and when I got to advanced it was already English.  However, I went back and rebooted the computer to see if anything would change.  It did not.  I am still getting Chinese news and updates when I open the Edge browser.

Thanks for the assist.

Steve

I propose to download the update in the Microsoft Store - Language Pack .
Again, I thank you for trying. Still getting Chinese.

@Andrzej1 

 

It is day four and this morning the Chinese is gone.  Have no clue what happened.  I do appreciate you trying to help me with this situation.

 

@Samman01 

This is great news!
But it would be fun to learn Chinese - translations are not always good.

The new Edge(release) is displaying only in Chinese - Microsoft Tech Community

Going to stick with English and Spanish for now. lol
I am having the same problem and have tried all the suggestions. Guess I will wait until day 4 and see what occurs.

@ChazzO 

This happened to me but cleared up on it's own after 4 days.  A week or so later it happened again.  Another 4 days and it was gone and returned to English.  My biggest concern is that I received a notification from one of my credit card companies that someone was trying to log into my account.  Not sure if it is related or not but does cause some concerns.  Both times mine changed to Chinese from English.

@Samman01 

How the Chinese returns - perform a scan:

Microsoft Safety Scanner Download | Microsoft Docs

@Andrzej1 

Thank you.  I have Malwarebytes but I will try this also.  

@Samman01 

I'm guessing this extension is the cause of your problems - see this discussion:

Edge painfully slow to load save file and download dialog box - Microsoft Tech Community

 

@Andrzej1 

Thank you for the suggestion. 

I do not use Malwarebytes and it appears it was not an extension problem.

The original problem occurred the day after a system update. Edge appeared normal until I opened a blank tab and it was in Chinese. Edge would not translate the language on the page but I copied the text on the page and pasted it into a translator which identified it as Chinese.

After a lengthy troubleshooting process of trial and error I was finally able to resolve the problem. The steps included turning off Profile/Sync, clearing cookies and browsing data (several times), checking the Languages setting and changing it to another language and then back to English, then finally repairing Edge which disabled all extensions. During each of the steps I would try to change the blank tab language to English but it would not change. Hoping the problem would remedy itself, as another person mentioned, I enbled all of my previous extensions, logged into my home page sites and resigned my self to seeing Chinese on a new blank tab page. Still frustated, I tried changing the language to something other than English. I changed to languae to Spanish and it worked. After this success I was able to change the language back to English and all is well now. 

@ChazzO 

 

Mine has opened in Chinese twice over the last 2-3 weeks or so.  In both cases it went back to English after four days.  I do have Malwarebytes.  I did have the 30 day trial but then bought the whole package when the trial ended.  That appears to be when the problem started.  I followed the posting that was put on this site about the Malwarebytes update and I did perform that function.  Hoping that solves any future issues but if not, I will try changing languages as you did.