Edge on Mac was excellent. Something's gone wrong.

%3CLINGO-SUB%20id%3D%22lingo-sub-1638038%22%20slang%3D%22en-US%22%3EEdge%20on%20Mac%20was%20excellent.%20Something's%20gone%20wrong.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1638038%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20been%20using%20Edge%20on%20Mac%20since%20early%20beta%2C%20and%20it%20has%20been%20always%20been%20excellent.%20So%20much%20so%20that%20I%20quickly%20ditched%20Chrome%20and%20Safari.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERecently%2C%20however%2C%20I've%20been%20real%20problems%20with%20it%20when%20doing%20any%20kind%20of%20site%20editing%20(SharePoint%20%2F%20WordPress%20%2F%20Elementor)...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPages%20freezing%2C%20links%20becoming%20unclickable%2C%20web%20parts%20becoming%20unresponsive%2C%20web%20app%20elements%20such%20as%20tabs%20locking.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPreviously%20I've%20been%20able%20to%20work%20with%20multiple%20browser%20tabs%20without%20any%20issues.%20Now%20I'm%20regularly%20having%20to%20reduce%20the%20number%20I%20have%20open%2C%20and%20then%20restart%20Edge%20when%20this%20doesn't%20help.%20It's%20negatively%20affecting%20my%20workflow.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20reluctantly%20had%20to%20switch%20back%20to%20Chrome%20in%20order%20to%20meet%20a%20deadline%20today.%20Edge%20is%20unusable%20for%20anything%20other%20than%20basic%20browsing%20at%20the%20moment%2C%20which%20is%20awful%20because%20I've%20been%20championing%20it%20across%20our%20organisation!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20using%20macOS%20Catalina%2010.15.6%20and%20Edge%26nbsp%3B%3CSPAN%3E85.0.564.44.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1640975%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20on%20Mac%20was%20excellent.%20Something's%20gone%20wrong.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1640975%22%20slang%3D%22en-US%22%3E%3CP%3EAn%20example%20from%20this%20morning...%20using%20Outlook%20Web.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1)%20When%20managing%20emails%2C%20as%20I%20move%20mouse%20to%20click%20%22Delete%22%2C%20%22Flag%22%20or%20%22Pin%22%2C%20the%20icons%20disappear%20and%20become%20unclickable.%20Had%20to%20restart%20Edge%20to%20resolve.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E2)%20Composing%20an%20email.%20I%20can%20click%20%22Attach%22%2C%20however%20I%20cannot%20click%20%22Browse%20this%20computer%22%20from%20the%20drop-down%20menu.%20The%20finger%20cursor%20changes%20to%20an%20arrow%20cursor.%20Cannot%20interact%20with%20secondary%20menus%20in%20the%20web%20app%20at%20all.%20Another%20restart%20required.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20kind%20of%20behaviour%20happening%20across%20multiple%20web%20apps...%20SharePoint%2C%20Outlook%20Web%2C%20WordPress.%20Very%20frustrating.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I have been using Edge on Mac since early beta, and it has been always been excellent. So much so that I quickly ditched Chrome and Safari.

 

Recently, however, I've been real problems with it when doing any kind of site editing (SharePoint / WordPress / Elementor)...

 

Pages freezing, links becoming unclickable, web parts becoming unresponsive, web app elements such as tabs locking.

 

Previously I've been able to work with multiple browser tabs without any issues. Now I'm regularly having to reduce the number I have open, and then restart Edge when this doesn't help. It's negatively affecting my workflow.

 

I've reluctantly had to switch back to Chrome in order to meet a deadline today. Edge is unusable for anything other than basic browsing at the moment, which is awful because I've been championing it across our organisation!

 

I'm using macOS Catalina 10.15.6 and Edge 85.0.564.44. 

1 Reply

An example from this morning... using Outlook Web. 

 

1) When managing emails, as I move mouse to click "Delete", "Flag" or "Pin", the icons disappear and become unclickable. Had to restart Edge to resolve. 

 

2) Composing an email. I can click "Attach", however I cannot click "Browse this computer" from the drop-down menu. The finger cursor changes to an arrow cursor. Cannot interact with secondary menus in the web app at all. Another restart required. 

 

This kind of behaviour happening across multiple web apps... SharePoint, Outlook Web, WordPress. Very frustrating.