Edge not recognizing Xbox controllers (for Xbox cloud gaming) anymore

Copper Contributor

This problem is now present since around 6 months or longer, some update in Edge totally broke gaming controller support. Problem is reported by countless people on here too:







and so on.


Would be nice if someone would look into this and fix it.


Can be easily tested on:




Xbox 360 controller with wireless adapter connected to Windows 11 pc.


Edge: doesnt work

Chrome: works

Firefox: works


The problem seems to be related to Xbox 360 controllers. I have tested a Xbox One controller via Bluetooth, that one is recognized in Edge (also Chrome and Firefox of course). Xbox 360 controller via Windows wireless USB adapter, not recognized in Edge (working in Chrome and Firefox).

18 Replies

@makedir Not just Xbox 360 controllers. I bought a PowerA Enchanted wired Xbox One controller, and it's not detected just by the Microsoft Edge browser; it works with other platforms, though. It's pretty upsetting, because edge cloud gaming works the smoothest, and it has that new feature called "clarity boost," which improves visuals a lot. I discovered a workaround that allowed me to play on Edge Cloud. There is an extension for Microsoft Edge called "XCloud keyboard and mouse," which basically remaps your buttons from an Xbox controller to a keyboard and mouse. It works fine and is optimized, but the input lag is a problem here. I honestly don't know; I only tried it for a short time, so I can't pass judgment. However, you may be able to customize the game settings to your liking. 

I know that addon, it costs money now. I dont see a reason to use it, I want native support from MS for mouse and keyboard, not something like this.

Answer from some MS dev please on this problem?
You can use unlimited trials with it if you want. Just use temporary emails to create fresh accounts within 3 days after expiration date tho. I hope it helps.

Hi @makedir, thank you for using Microsoft Edge and providing this piece of feedback! Could you please try using your gamepad with Edge Canary version 112.0.1689.0 or above? We have made some fixes to this version that should help. You should be able to get it from here: https://www.microsoftedgeinsider.com/en-us/download/canary


Please let us know if it works for you. 

Thank you very much for the quick fix. Ive tested 112.0.1697.0 and can confirm, the problem seems to be solved. My xbox controllers are now working in Edge, Xbox 360 controller included.
Fantastic! I am glad to know that your gamepad is working now :)


Hi Gabriel - I'm having this same issue as well; neither Bluetooth Series S/X nor X360 controllers via USB wireless adapter are working in XCloud (X360 one hasn't been working for months now). I've just downloaded the latest Canary build as suggested in your previous post (Version 113.0.1738.0 (Official build) canary (64-bit)) but Edge still refuses to recognise any controllers.


Is there anything else I can try? 


Thanks in advance!

@xclouder make sure it is not a local issue with your controller/pc. Test if they work in Chrome/Firefox by visiting https://gamepad-tester.com/ but not working in Edge. I had no problems anymore since the above test version of Canary Edge.

Thanks for replying, @makedir - appreciated!

Tested your link in Brave (also Chromium-based as far as I'm aware) and all buttons and sticks registered, so definitely seems to be an Edge issue. The strange thing is that a few weeks ago I managed to have the Series X pad working in Edge, but now neither do. For reference, the X360 pad works fine in locally-installed Game Pass titles.

Please be more precise.

Chrome(Brave) version: https://gamepad-tester.com/ working yes/no
Edge version (both stable, and canary): https://gamepad-tester.com/ working yes/no

Also for both scenarios two times, with 360 controller and one/x/s controller.

Ive just tested myself:

Chrome 111.0.5563.65: xbox one bt working
Chrome 111.0.5563.65: xbox 360 wifi usb dongle working
Edge 111.0.1661.41: xbox one bt working
Edge 111.0.1661.41: xbox 360 wifi usb dongle NOT working (intended as of this topic)
Edge Canary 113.0.1738.0: xbox one bt working
Edge Canary 113.0.1738.0: xbox 360 wifi usb dongle working

Ah, that's interesting then. My results are:

Brave is up to date
Version 1.49.120 Chromium: 111.0.5563.64 (Official Build) (64-bit):
- Series X Bluetooth working
- X360 via USB wifi adapter working (the older black adapter on the extension cable, rather than the newer stick-types)

Microsoft Edge
Version 111.0.1661.41 (Official build) (64-bit)
- Series X Bluetooth working (shows as HID-compliant game controller (STANDARD GAMEPAD Vendor: 045e Product: 0b13))
- X360 via USB wifi adapter - not recognised

Microsoft Edge
Version 113.0.1738.0 (Official build) canary (64-bit)
- Series X Bluetooth working (shows as HID-compliant game controller (STANDARD GAMEPAD Vendor: 045e Product: 0b13))
- X360 via USB wifi adapter - not recognised

Just to be sure, now that the Series X pad was showing in Edge, I checked via xbox.com/play and now for some reason the Series X is working - I have no idea why this would be the case, nothing has changed on my desktop as I've been working on a different machine! The only thing I can think of is that turning the pad and BT off to focus on work, then turning back on again just now (note: NOT re-pairing) to test has somehow made a difference. Very strange indeed.

However, the X360 pad is still not recognised in either form of Edge, whereas it's fine in Brave. I guess it's one of those situations where there's half a workaround, so how far do we push in order to try and fix the X360 issue? Ideally, would be good to sort as we only have one Series X pad between three of us in the house, but countless X360 ones!

Understand if this is as far as anyone is willing to go to resolve though :)

@makedir thanks for making the extra questions and help to clarify the issue!


@xclouder thanks for the report! I am glad that your Xbox Series X controller is working again :) Just want to make clear that you can go back using the "regular" Edge instead of Edge Canary when it reaches version 112. 


About the Xbox 360 gamepad, could you answer these questions?

  • What model is your Xbox 360 USB adapter? Could you please send a link with the product information and brand?
  •  What model and brand is your Xbox 360 gamepad? 
  • Could you also please send your Xbox 360 gamepad HID (Human Interface Device) information? If so, please follow these steps:
    • Navigate to  HID Explorer (nondebug.github.io).
    • Click "Connect", select your device, and connect it. It might help to have only the 360 gamepad connected so less options are shown. You can confirm that you have selected the correct gamepad if moving the analog sticks make the number in the "Input report" area to change.
    • Please copy all the information in the "Device info" text box and send it here.


@GabrielSB / @makedir 

Hi both - apologies for delayed response, work blew up a bit! Please see details below as requested though:

What model is your Xbox 360 USB adapter? Microsoft Xbox 360 Wireless Receiver for Windows is all that's written on the underside of the unit, strangely no model number etc. (it is an official one though). Label on the lead itself says Model 1086 P/N X809782-005 - same as this model (Amazon.com: Original OEM Microsoft Xbox 360 Wireless Black Receiver for Windows - Model: 1086 P/N: X...) although for some reason that has a 009 suffix rather than 005. May be market-specific

What model and brand is your Xbox 360 gamepad? Official controller. Detail inside battery cover is X801769-009 and is same as (Amazon.com: Xbox 360 Wireless Controller - White (Renewed) for PC : Video Games)

Could you also please send your Xbox 360 gamepad HID (Human Interface Device) information?

productName: Controller (Xbox 360 Wireless Receiver for Windows)
vendorId: 0x045E (1118)
productId: 0x02A1 (673)
opened: false
Usage 0001:0005
Input reports: 0x00
Input report 0x00
16 bits (bits 0 to 15)
Usage: 0001:0030 (Generic Desktop > X)
Logical bounds: 0 to -1
Physical bounds: 0 to -1
16 bits (bits 16 to 31)
Usage: 0001:0031 (Generic Desktop > Y)
Logical bounds: 0 to -1
Physical bounds: 0 to -1
16 bits (bits 32 to 47)
Usage: 0001:0033 (Generic Desktop > Rx)
Logical bounds: 0 to -1
Physical bounds: 0 to -1
16 bits (bits 48 to 63)
Usage: 0001:0034 (Generic Desktop > Ry)
Logical bounds: 0 to -1
Physical bounds: 0 to -1
16 bits (bits 64 to 79)
Usage: 0001:0032 (Generic Desktop > Z)
Logical bounds: 0 to -1
Physical bounds: 0 to -1
10 values * 1 bits (bits 80 to 89)
Usages: 0009:0001 (Button Button 1) to 0009:000A (Button Button 10)
Logical bounds: 0 to 0
4 bits (bits 90 to 93)
Usage: 0001:0039 (Generic Desktop > Hat Switch)
Logical bounds: 1 to 8
Physical bounds: 0 to 4155
Units: 1
18 bits (bits 94 to 111)
Logical bounds: 0 to 0


Think that's everything - hope it's of use. As I mentioned previously, absolutely no issues with the X360 pad running games locally ie. installed vs Xcloud.

@GabrielSB / @makedir
Hi guys! Just wondering if the above info is of any use in fixing the X360 pad issue, or whether this is far as we can take it?

Hi! Of course, the info you provided is very helpful! I had a look and tried replicating your issue in Edge 112.0.1722.64 (Official build) (64-bit), but it worked as expected. I have been able to use the X360 gamepad in xcloud too. For the test, I used a Microsoft wireless receiver just like the one in the link and a Microsoft Xbox 360 wireless gamepad. I was wondering if you are still having issues with this. Is it the case?
Hi @GabrielSB - thanks for getting back to me. I've tried again just now in Microsoft Edge
Version 115.0.1866.0 (Official build) canary (64-bit) but same applies - gamepad not recognised (using the X360 version with the adapter).

Pad also not recognised in https://gamepad-tester.com/ in Edge but using the tester in Brave and logging in to Xcloud also in Brave both worked ie. I could play a game.

This issue seems limited solely to Edge (at least on my machine).
Hey @xclouder, to have a deeper look on your specific situation, could please send us your Edge histogram data?

To make we have a clean snapshot, please fully close Edge and restart it. Also make sure that you have only this gamepad connected to your machine. Then, repro your issue by navigating to https://gamepad-tester.com/ and press the gamepad buttons in an attempt to make it show up in the page. After doing it, please navigate to edge://histograms/Microsoft.GamepadWgiDataFetcher , copy all the information shown on the page (ctrl+a and ctrl+c), and send back to us here.

Hopefully this will help us to understand what is happening in your machine.