Edge for Android keeps going to desktop mode

Copper Contributor

I am using Edge on my Android phone 

I've got the settings set to always use mobile site but it keeps going to the desktop site 

Any idea on how to get it so it stays on mobile? 

23 Replies
Are you using the stable build or Dev or Beta?
Since when this problem started?
Does it happen for all websites?
Are you facing the same issue in InPrivate browsing mode?

@Mike_Wells I'm having the same exact issue.

 

Can't pinpoint exactly when it started, but I feel like it was around the time the "Bing" button was introduced at the bottom center.

 

When I uninstalled and reinstalled the app it was fine until I needed to view a site in desktop mode.  From there on out, the previous behavior picked right back up.

 

Easy reproduction step for me:

1. Perform a search from address bar using Bing as default search provider

2. Bing returns results (this is in mobile view)

3. Scroll to bottom and click the see more to view more results

4. Page reloads, but reloads in desktop view

Launch the Chrome web browser on Android. ...
Tap on the 3 vertical dots for the menu.
The desktop site can be enabled by selecting the checkbox.
The page will reload automatically on your browser.
You will be able to view the site's desktop version on mobile devices. {link removed by admin}

@Eleanor32 this thread is about the Edge browser on Android device, not the chrome browser.

 

The desired functionality is to have sites load in mobile view not desktop view.

I'm also having the same issue. I posted on the community forums and an admin told me to post here, so here I am.

I'm on Android v13, and I'm on a Samsung Galaxy Fold4. Edge is version 112.0.1722.59 (beta). I attached a screen recording. 

@Reza_Ameri 

Are you using the stable build or Dev or Beta?

I'm on Beta


Since when this problem started?

A couple weeks ago or so. So probably a recent update. 


Does it happen for all websites?

Not sure but definitely a lot


Are you facing the same issue in InPrivate browsing mode?

Yup, just tried it even on Bing.com

I am also experiencing this. I am in the stable channel (Edge 112.0.1722.59) on a OnePlus 9 Pro.

 

I'm not really sure exactly what triggers it, but if you have the problem, it will happen so often that you can't miss it. It's like every 3rd page load will be randomly switched between desktop mode and mobile mode. It happens constantly.

 

Super annoying, especially when YouTube in InPrivate tabs sometimes claim that the browser is considered unsafe, and won't let you log in (unless you're in the right mode, and the page reloads after entering the e-mail, so it's random if you get the right mode).

 

Please look into this, it's mildly infuriating wherever I go at this point!

Thank you for the information, please run a test and see if the problem persists in the stable version too?
Check Google Play and see if there is any new update for the Microsoft Edge Beta.
Make sure file a report using the feedback option in Microsoft Edge.
I had the same issue and resolved it by uninstalling/reinstalling the Edge app on my phone.

@squizur 

Thank you!

Reinstalling Edge solved the problem for me as well.

@squizur 

Thanks for the tip, trying this out. I haven't tested it too much, but it looks promising so far. :)

Thank you for the update.

@Reza_Ameri reinstalling has seem d to fix the issue. I haven't seen it happen since. 

Glad it solved the problem and thank you for letting us know.
I have sort of figured out what it's doing, when you use desktop site it saves this in site settings, go to settings then privacy and security then site settings, scroll to the bottom to desktop site, if you have requested a site to be a desktop site it it saves this here and keeps opening as a desktop site you can remove it by pressing on the site and pressing remove or you can request it to be a mobile site from here, you can also go to settings general and change the option to always view a desktop site as default or as mobile site as default.

I use my phone for Microsoft rewards and I used to be able to just search what I needed for in mobile view then when I wanted it to be a desktop site I could just press that and it would stay as a desktop site untill i closed the tab then it would revert back to being mobile again but for some reason they have messed it up and it now saves the site to stay as a desktop.

I'm going to keep messing around with it, and try and change some settings but its just a pain having to keep going in to settings and changing things when it was just a press of one button.

You can also go in to privacy and security and then clear browser history leave cookies and auto form fill unchecked or other ones if you want to keep certain data but check site settings and make sure you change the amount of days to all time this helps with clearing some of the annoying settings.

Hope this helps and if anyone has any progress on actually fixing this let me know
This! I've been trying to find a solution to this for years. Uninstalled edge multiple times and the frustration comes back after syncing. And just like you described, I used Google search in desktop mode once and all Google and related sites were added to desktop mode. Thanks bunch of times!
This should be marked as best response. It solved my issue without needing to reinstall the browser. Kudos!

@Tonyfoster16 

Get this man a pint! (If you don't drink then a soft drink!) 

 

This desktop view 'bug' has been driving me daft this week, thanks to your advice its resolved now,  thanks for taking the time to post. 

 

Useless information, you've the same name as my Dad's old workmate 

@Mike_Wells no worries, don't know why but sometimes it seems to sort it self then other times all my tabs get moved around and it stops working again, you would think Microsoft would just sort this out, glad it's helped though