Edge Dev is crashing on startup

Iron Contributor

I used Edge dev earlier this morning. Did and app upgrade and had to reboot. Since then, Edge Dev crashes on launch. Edge and Edge Canary are starting just fine. Anyone else run into this issue? 

 

FWIW - I did a repair with no change and deleted and reinstalled and still no joy. Any insight is appreciated.

 

I just read the lastest Dev channel update thread. I have to assume the browser updated and was waiting for the restart. It seems I am now one of the many that are having the crash on launch issue. I love being part of the crowd :)

7 Replies
Yes, this was an issue on Canary. After the last update, it is an issue on dev. It crashes in anything that is not InPrivate, including trying to go to the settings so you can clear cookies/sessions. It's a mess, there's no worse bug than one that requires a full uninstall and reinstall to fix.
Welp, I did the uninstall and reinstall and that made no difference. Though I did not blow up the Edge Dev folder and its contents. I'll wait for the next update and repair it.

@cjahn50 Same

yeah. hopefully fixes soon!
The maddening thing is the refusal of the edge team to engage on this issue and/or treat it with any urgency. This isn't a "oh I can't do this on this site" issue. It's a "this thing doesnt' work AT ALL" issue.

@cjahn50Good morning, today I downloaded from the Microsoft catalog website (catalog.update.microsoft.com) and manually installed edge dev version 125.0.2518.0, it solved the startup problems for me

I just did a repair and Dev was updated to 125.0.2518.0. Launched normally and has stayed up so far. Thanks for the tip!