Edge crashing on launch - MacOS Catalina 10.15.4

New Contributor

I have tried all insider channels and the official release of Edge and they all behave the same: crashing as soon as I try to launch.

MacOS Catalina 10.15.4


11 Replies

@ivodurchev, I don't have this issue on any of my Macs.  Try deleting (or renaming) the Edge data folders.  Here's the full path:


/Users/YOUR-USER-NAME/Library/Application Support/Microsoft Edge

/Users/YOUR-USER-NAME/Library/Application Support/Microsoft Edge Beta

/Users/YOUR-USER-NAME/Library/Application Support/Microsoft Edge Canary

/Users/YOUR-USER-NAME/Library/Application Support/Microsoft Edge Dev


Once you do this, relaunch the app.  You'll need to recreate the profiles (or logon), but this should work.

@RichardBottiglieri  Tried this few times with no success. The apps still crash on startup.

best response confirmed by ivodurchev (New Contributor)

Today's update has fixed the issue and the browsers are now functioning as expected

@ivodurchev Thanks for reporting this to us. I had brought your original post to our mac team and will update them with the good news! If this happens again, please feel free to let us know and we can do more advanced troubleshooting.


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Deleted I have a strange issue on both 10.15.4 and now 10.15.5. Edge while trying to launch private window crashes!

@viveksiv Thanks for letting us know. To confirm, which channel and build number of MS Edge are you using? And did you download MS Edge from Safari, by any chance? (If so, there's a known issue with that, so we'd recommend trying to download it from a different browser.)


Fawkes (they/them)
Project & Community Manager - Microsoft Edge



I am using Version 83.0.478.37 (Official build) (64-bit). Downloaded using Firefox on my Mac. The previous build was working fine. This is a bit frustrating as I have to use firefox now for my inprivate sessions. 


Is there an easy way to generate crash logs in Mac? I am not too well versed on Mac as I was with Windows, and hence the question. 



I renamed the folder as in one of the posts above, and with a clean profile, things worked - as in, was able to launch a private browser window. Does this say something? Maybe my profile got corrupted or something. 

@viveksiv Thanks for the update! The team confirmed that this initially seemed to be related to a known issue, but I will pass along your most recent messages to confirm if the behavior that you're seeing is aligned with the current bugs.


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Deleted Hi! I want to chip in about the "new InPrivate window crashing Edge on OS X" issue.

It's been happening to me as well. I've debugged it a bit, and it seems this issue is happening when you go to the InPrivate window when you have Default Theme set to "Light".

When I switched my theme to "Dark" or "System Default" (which is also dark) and tried accessing the "new InPrivate" window, it started to work.

The "new InPrivate" window also kept working when I switched back to "Light", but only in the case I had opened the private window with dark theme before. I think it's because some assets were preloaded at this point. Once I restart the browser and open it with the "Light" setting without first opening with the "Dark" setting, the "new InPrivate" link again crashes the process.

I'm guessing very wildly here, but I think it may be related to these changes:
Release notes
> Version 81.0.416.53: April 13
>We heard from users it can be difficult to distinguish a normal browsing window in dark theme from an InPrivate window since both window frames are dark. The new solid InPrivate blue pill in the top right corner helps reassure users they are browsing InPrivate.

Sorry for hijacking this thread but I didn't find any other reference to this bug. I can create a new thread, if necessary.


@ivodurchev I waited for the daily update, but Edge still would not launch.  When that failed, I tried deleting Edge and reinstalling from dl.  No success.  I then deleted Edge with all associated files (plists, etc.), emptied trash, rebooted, and reinstalled, but it none of that worked either.  The only way I could get it to open was by resetting the PRAM/NVRAM (holding down option+command+P+R at boot).  I did not have to delete or reinstall after the reset; the app just opened as expected.  Of course, I had to set up everything again, but...


My machine is a new 2019 MBP running macOS 10.15.5.

I was running whatever version of Edge Canary was current  on July 7, 2020 when the problem first occurred.  July 8th update installed via MS Autoupdate, but did not resolve problem.  Before this incident, I had had no issues with Edge.  I am also running it on two other MBPs of different vintages running the same OS with no problems.