SOLVED

Edge can't use the mic in the Google Translate page

Regular Contributor

Edge Canary and Dev don't seem to know how to use a microphone. I tried the following steps both on a workstation connected to a Logitech's Brio webcam's microphone, and a Surface Pro 4 using the built-in microphone.

 

1- Go to Google's translate page www.translate.google.com

2- Select a language to translate from
3- Click on the microphone icon in box for the language of originAnnotation 2019-05-14 223830.jpg

4- Authorize access to mic if requested then start speaking when prompted
5- Expected result: Edge uses the mic to listen to what I say
6- What's happening: Edge doesn't pick up anything from the mic.

 

Google Chrome has no difficulty using Brio's microphone nor the Surface Pro 4's. Windows' Voice recorder also has no difficulty using the same mic.

56 Replies

@HotCakeX I've used the feedback button in Edge Dev as well so I hope they'll notice it!

@HotCakeX 

 


@HotCakeX wrote:

I'm assuming it's different from Google translate voice because that one works fine for me


Does it work on the test page? Web Speech API Demonstration  

 

@Noel Burgess 


@Noel Burgess wrote:

@HotCakeX 

 


@HotCakeX wrote:

I'm assuming it's different from Google translate voice because that one works fine for me


Does it work on the test page? Web Speech API Demonstration  

 


yes, it works on there too, even though the performance of that site is bad. i speak hello and then after 3-4 seconds i see the word appear there.

 

so far, only Google search at Google.com is having problem.

 

which I don't really care since I use Bing. the problem could even be an intentional block from Google's side. because the evidence shows Web Speech API works, on Google translate and that Web Speech API test site. 

 

Just updated my Canary build and it looks like the bugs I've mentioned earlier are fixed :)
Waiting for Dev Build updates now :D

@florianSB 

That's nice, although Google speech search is still not working on Canary for me.

do you still use mspeech commandline switch ?

I've just tested it with and without any flags and it seems I don't need the flag anymore. Google speech search is working fine as well (just make sure to allow microphone access ... I usually disable permissions and forget to reactivate sometimes ^^).
Yeah mic is allowed, still doesn't work and same no internet error

I will reinstall Edge canary soon as I can and report back how it goes, hopefully it's just my Edge canary that's somehow corrupted and a reinstall will fix it.

@florianSB 

a Windows and Edge clean reinstall didn't fix it.

the speech to text even works on YouTube's voice search. so it works on YouTube, Google translate, Google's WebspeechAPI text site, just not on Google.com

 

i don't use Google as my search engine but this is very weird.

@HotCakeX ok so I have a really strange new behavior now ^^.

In Canary it works ... but sometimes the whole browser crashes O_o

In the newest Dev its stuck in the "listening..." screen :|

lol very weird

@HotCakeX Crashes are pretty easy to reproduce now, just try to use voice search on Google 2-3 times in a row. This is (in my case) true for Canary and Dev right now where Dev usually doesn't even recognize speech and just shows "no internet connection".

Oh, yeah the same false error shows up on my screen too every time i test it

@HotCakeX Having the same issue here. Running the latest stable build (I think) 88.0.705.74.

 

 Youtube voice search, but google search just gives me an error. Really annoying.

Yeah, same here still not working
Edge Version 90.0.803.0 (Official build) canary (64-bit)

Well, almost 2 years later and problem keeps the same, actually, it's worse if you think that ALL the others browser have the same problem, just Chrome is okay to use. That's terrible.

@oicaua33 The latest tests I've done with Edge Canary were actually pretty successful and stable using my own app AND on the Google Search page as well. In Edge Dev it was working for a while but seems to be gone again (or behind the flag? idk).

Don't expect any other browser to work soon btw, since the company (Google, Microsoft, Mozilla, Apple etc.) has to run the speech recognition servers. Google is doing it for ages (this includes Android), Microsoft and Apple are doing it, but only for their own OS (Windows: Cortana, MacOS, iOS: Siri) and Mozilla can't afford it :(

i also have this when i click in mic icon it says can't connect to the network i have already given access mic in microsoft edge browserScreenshot (16).png