Edge can't use the mic in the Google Translate page

Steel Contributor

Edge Canary and Dev don't seem to know how to use a microphone. I tried the following steps both on a workstation connected to a Logitech's Brio webcam's microphone, and a Surface Pro 4 using the built-in microphone.


1- Go to Google's translate page

2- Select a language to translate from
3- Click on the microphone icon in box for the language of originAnnotation 2019-05-14 223830.jpg

4- Authorize access to mic if requested then start speaking when prompted
5- Expected result: Edge uses the mic to listen to what I say
6- What's happening: Edge doesn't pick up anything from the mic.


Google Chrome has no difficulty using Brio's microphone nor the Surface Pro 4's. Windows' Voice recorder also has no difficulty using the same mic.

56 Replies


The mic works for me when I use Skype on the Canary build.


Not the same as what your doing, but it picks up and uses my webcams mic(Logitech  C270) using Windows default drivers for mic & video as there are problems with using the Logitech drivers and running Core Isolation - Memory Integrity, probably Logitech won't update their certificates for it;)


So try using the default drivers for your mic.

Device manager

find driver(Audio inputs outputs)

select update driver

select browse computer

select let me pick

select default "Audio inpoint"Audio EndpointAudio Endpoint



@Deleted I checked my driver and it is not signed by Logitech but by Microsoft. It uses the Generic USB Audio Device. The driver provider is Microsoft and the driver date is 2019-05-08. My Surface Pro 4 has the same problem using its own microphone.


Try the Skype online(if you have a Skype account):

and use the Echo / Sound Test service call, and see if that works. works fine. Try and see if your mic works.


Ok, after I remembered to allow the mic, I tested both in Chrome and Canary Edge.

It worked in Chrome, but not in Edge.


Sorry I couldn't help, but at least confirm the bug.

Maybe it has something to do with the User agent string the translator expected?

I don't know.

@Deleted Confirming the bug is just as important at this point in the process. It gives Microsoft an idea of the extent of the problem.

@NicolSD Just to confirm, I've tried with other websites, like and they all seems to work fine. The issue only happens with


I sent Google feedback including the information from edge://version/


I also have this issue with Google voice search (the mic icon on the right of the search box).

And Duolingo when taking questions needing mic input.

I've tried two computers and they both don't work, but they do work with Google Chrome.


I'm guessing it's not the issue with Google, but something with Microsoft Edge itself.

It seems like the browser has no problem receiving the mic input, but it couldn't process it or send it to the server.



I did some more troubleshooting.

I just tested the Windows key + <H> hot key function (Text to speech) and that works.

But using the OS's embedded controls; isn't the same as using the sites embedded controls.


Still it's an option/work around until this gets fixed.

Specially if one has a gaming mouse that can use macros.

@Deleted Good job, Cliff, except that it only listens for English. With Google's translate mic, you can speak in a foreign language.

@NicolSD You're right, and it really is an issue for me while learning a foreign language with Duolingo. I believe it will also be a problem for some people who need to use voice input, but Windows' speech-to-text doesn't support their native language.


We're in dev channel version now, and this problem still persists.

I did a bit of testing and find out the problem isn't about mic input, but about voice recognition.

For example, if you use an online voice recorder, like the service below, it does work and record your voice:


But when you use any voice recognition service, like Google voice search, Google Translate or the speech to text service below, it doesn't work:


Both the links above work fine in Google Chrome. I tried changing Edge's user agent to Chrome, and it still doesn't work.

Let's hope Microsoft will fix this issue before the stable version comes out.

best response confirmed by NicolSD (Steel Contributor)
My guess is that all these Tools use the WebSpeechApi which only works on Google Chrome/Chromium (at least the recognition part) because Google uses it's own cloud servers for the audio transcription. Since the new Edge is basically Chromium it probably thinks that the WebSpeechApi is supported and breaks. The API behaves very strange currently in Edge.

Hey, after having the same issue and not getting a real answer THANK YOU. Your response makes the most sense to me, I appreciate your answer and details given. I sensed the mic was working in Edge but it was not giving a result as if it just hit a wall so your answer makes a lot of sense to me. Much appreciated. :cool:



 @MissyQ @Deleted 


Any chance of an official reaction to this bug that's apparently affecting lots of users?


To recap: speech recognition doesn't work when using Edge to access some Google properties like The microphone input is recognized at other sites and at the affected sites when using Chrome.  

@Noel Burgess Thanks for tagging! This is actually a known issue, and the team is working on it. I'm happy to follow up here once we know the fix is in place. :)


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge

Any news  on that?@MissyQ 

@Deathmo1976 Appreciate the poke for an update here. Unfortunately I have no new updates to provide. The team is still working on it, though!


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge