Home

edge blurriness on intel gpu

%3CLINGO-SUB%20id%3D%22lingo-sub-1157547%22%20slang%3D%22en-US%22%3Eedge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1157547%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20laptop%20has%202%20gpu.%20One%20is%20intel%20hd%204400%20default%20for%20everyday%20use%20including%20browser.%20The%20other%20is%20nvidia%20geforce%20840m%20which%20activates%20only%20for%20games.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENow%20using%20edge%20chromium%20with%20the%20default%20intel%204400%2C%20I%20see%20this%20blurriness%20on%20the%20font%20text%20occasionally%20during%20loading%20and%20moving%20scrolling.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBeing%20annoyed%20at%20this%2C%20I%20forced%20the%20edge%20to%20use%20the%20geforce%20840m%20and%20the%20blurriness%20went%20away%20and%20the%20font%20was%20clear%20all%20the%20time.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20optimization%20for%20edge%20to%20use%20the%20intel%20gpu%20better%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1157761%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1157761%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3EI'm%20using%20an%20Intel%20GPU%20(630)%20which%20is%20inside%20my%20CPU%20i7%207700K%2C%20everything%20looks%20clear.%3CBR%20%2F%3Ecould%20you%20specify%20these%20details%3F%3CBR%20%2F%3E1.%20what's%20your%20OS%20and%20version%3F%3CBR%20%2F%3E2.%20which%20channel%20of%20Edge%20are%20you%20using%3F%3CBR%20%2F%3E3.%20is%20your%20Intel%20IGPU%20driver%20updated%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158418%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158418%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20im%20using%20windows%2010%2064%20bit1909%3C%2FP%3E%3CP%3E2.%20im%20using%20beta%20edge%26nbsp%3B%3CSPAN%3E%26nbsp%3B80.0.361.48%20(Official%20build)%20beta%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E3.my%20intel%20hd%204400%20is%20using%20the%20latest%20driver%20from%20intel.%20driver%20version%20is%26nbsp%3B%3CSPAN%3E20.19.15.5107%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158476%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158476%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F545211%22%20target%3D%22_blank%22%3E%40bfchb%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ecan%20you%20check%20your%20Windows%20appearance%20settings%20and%20see%20if%20they%20look%20like%20this%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22dsdasd.png%22%20style%3D%22width%3A%20830px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F169000i25955CFEC309AC84%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22dsdasd.png%22%20alt%3D%22dsdasd.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158546%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158546%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20same%20exact%20default%20configuration%20like%20yours.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158590%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158590%22%20slang%3D%22en-US%22%3ECan%20you%20take%20a%20screenshot%20of%20the%20blurriness%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158612%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158612%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3Bsomething%20like%20this%20but%20then%20it%20goes%20into%20focus%20when%20i%20click%20on%20the%20background.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20noticed%20when%20i%20turn%20off%20hardware%20acceleration%20and%20using%20intel%20gpu%2C%20the%20blurriness%20doesn't%20appear%20at%20all.%3C%2FP%3E%3CP%3EThe%20only%20performance%20hit%20is%20on%20video%20playback%20on%20youtube%20or%20twitch%20with%20more%20skipping%20frames.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20when%20I%20use%20firefox%20with%20my%20default%20intel%20gpu%2C%20it%20will%20always%20remain%20blurry%20free.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158973%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158973%22%20slang%3D%22en-US%22%3EOh%20so%20the%20problem%20is%20HA.%20have%20you%20tried%20Chrome%3F%20if%20yes%20does%20it%20happen%20in%20it%20too%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1158986%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1158986%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Edoesn't%20happen%20on%20chrome%20either%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1161219%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1161219%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eanything%20else%20or%20updates%20feedback%20to%20to%20the%20team%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1161272%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1161272%22%20slang%3D%22en-US%22%3EHave%20you%20tried%20other%20channels%3F%20specially%20Canary.%3CBR%20%2F%3Ealso%20stable%20channel%20is%20now%20version%2080%20too.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162081%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162081%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Estable%20edge%20got%20on%20the%20same%20version%20as%20beta%20but%20still%20has%20the%20blurring%20effect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20now%20testing%20canary%20build%20and%20will%20report%20back%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E**update%3C%2FP%3E%3CP%3Eok%20on%26nbsp%3B%3CSPAN%3EVersion%2082.0.418.0%20(Official%20build)%20canary%20(64-bit)%2C%20the%20blurriness%20on%20intel%20gpu%20is%20gone.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Ethanks%20for%20suggesting%20this.%20I%20can%20now%20use%20edge%20without%20any%20complaints.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E**%20new%20update%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Ei%20jumped%20the%20gun.%20I%20still%20get%20blurriness%20on%20youtube%20videos.%20I%20leave%20it%20playing%20in%20normal%20mode%20not%20full%20screen%20and%20after%20awhile%20the%20surrounding%20area%20gets%20blurry.%20It%20is%20just%20like%20the%20screenshot%20i%20send%20up%20there.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162273%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162273%22%20slang%3D%22en-US%22%3EHmm%2C%20well%20for%20now%20set%20Nvidia%20GPU%20to%20be%20used%20for%20Edge%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162384%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162384%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eguess%20gotta%20leave%20it%20set%20on%20nvidia%20gpu%20then.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162474%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162474%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eplayed%20with%20an%20even%20older%20laptop%20that%20uses%20amd%20apu%20a8-4500m%20so%20graphics%20is%20radeon%20HD%207640g%20and%20it%20doesn't%20suffer%20the%20blurriness%20on%20edge%20stable%20version.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20im%20thinking%20that%20edge%20doesn't%20like%20intel%20hd%204400%20at%20all.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162557%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162557%22%20slang%3D%22en-US%22%3EHave%20you%20ever%20thought%20it's%20the%20other%20way%20around%3F%20that%20Intel%20graphic%20driver%20is%20not%20compatible%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162917%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162917%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20rolled%20back%20to%20the%20older%20driver%20for%20intel%20hd%204400.%20Still%20got%20the%20blurriness.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1162929%22%20slang%3D%22en-US%22%3ERe%3A%20edge%20blurriness%20on%20intel%20gpu%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1162929%22%20slang%3D%22en-US%22%3EObviously%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable

My laptop has 2 gpu. One is intel hd 4400 default for everyday use including browser. The other is nvidia geforce 840m which activates only for games.

 

Now using edge chromium with the default intel 4400, I see this blurriness on the font text occasionally during loading and moving scrolling.

 

Being annoyed at this, I forced the edge to use the geforce 840m and the blurriness went away and the font was clear all the time.

 

Is there optimization for edge to use the intel gpu better?

17 Replies
Highlighted
Hi,
I'm using an Intel GPU (630) which is inside my CPU i7 7700K, everything looks clear.
could you specify these details?
1. what's your OS and version?
2. which channel of Edge are you using?
3. is your Intel IGPU driver updated?
Highlighted

@HotCakeX 

 

1. im using windows 10 64 bit1909

2. im using beta edge  80.0.361.48 (Official build) beta (64-bit)

3.my intel hd 4400 is using the latest driver from intel. driver version is 20.19.15.5107

Highlighted

@Deleted 

 

can you check your Windows appearance settings and see if they look like this

 

dsdasd.png

 

Highlighted

@HotCakeX 

I have the same exact default configuration like yours.

Highlighted
Can you take a screenshot of the blurriness?
Highlighted

@HotCakeX something like this but then it goes into focus when i click on the background.

 

I noticed when i turn off hardware acceleration and using intel gpu, the blurriness doesn't appear at all.

The only performance hit is on video playback on youtube or twitch with more skipping frames. 

 

But when I use firefox with my default intel gpu, it will always remain blurry free.

Highlighted
Oh so the problem is HA. have you tried Chrome? if yes does it happen in it too?
Highlighted

@HotCakeX 

doesn't happen on chrome either

Highlighted

@HotCakeX 

 

anything else or updates feedback to to the team?

Highlighted
Have you tried other channels? specially Canary.
also stable channel is now version 80 too.
Highlighted

@HotCakeX 

stable edge got on the same version as beta but still has the blurring effect.

 

I am now testing canary build and will report back

 

**update

ok on Version 82.0.418.0 (Official build) canary (64-bit), the blurriness on intel gpu is gone.

thanks for suggesting this. I can now use edge without any complaints.

 

** new update

i jumped the gun. I still get blurriness on youtube videos. I leave it playing in normal mode not full screen and after awhile the surrounding area gets blurry. It is just like the screenshot i send up there.

Highlighted
Hmm, well for now set Nvidia GPU to be used for Edge
Highlighted

@HotCakeX 

guess gotta leave it set on nvidia gpu then.

Highlighted

@HotCakeX 

played with an even older laptop that uses amd apu a8-4500m so graphics is radeon HD 7640g and it doesn't suffer the blurriness on edge stable version.

 

So im thinking that edge doesn't like intel hd 4400 at all.

Highlighted
Have you ever thought it's the other way around? that Intel graphic driver is not compatible?
Highlighted

@HotCakeX 

i rolled back to the older driver for intel hd 4400. Still got the blurriness.

Highlighted
Obviously