Edge Beta - Two Factor Authentication (2FA) not working

New Contributor

I got the Edge Beta on Tuesday and tested the account login (i.e. created a Profile) yesterday with my work credentials.


When using the browser, the 2FA is not triggering from the Windows 10 credentials.  It is prompting for the 2FA each time I open the browser and try to access any of the O365 applications.  We have Chrome and Firefox configured with the Federated login along with the below extensions to automatically recognize the O365 account credentials upon opening the browsers.  IE 11 automatically recognizes the Windows 10 credentials sine we have "Enable Integrated Windows Authentication" and "User Authentication>Logon>Automatic logon with current user name and password" enabled.


To my understanding, the extensions use the same options selected in Internet Options as IE 11 to bring in the credentials and validate the 2FA upon the browser opening.  I have tried adding the Chrome extension to Edge Beta, but it will not recognize the credentials like Chrome and Firefox.  I've also tried creating a profile with my work account (with and without the extension on) to get Edge Beta to recognize the credentials and automatically validate the 2FA, but have not had any success.


Any advise on this would be greatly appreciated.  Or let me know if this version of Edge Beta does not support the automatic validation of the 2FA yet.


Chrome - Windows 10 Accounts


FireFox - Windows 10 Accounts Port

2 Replies

@Garon_Evans We're sorry that you are experiencing this behavior. Which build of Anaheim are you noticing this in? Also, which OS version are you using? Pasting the output of the first 3 lines of edge://version would be super helpful so we can help you debug this issue.







@Avi Vaid 


OS: Windows 10 Enterprise

Edge Version:



Also, I think the issue may be with how the Google and Firefox extensions work.  They both use the IE engine (Internet Options) for Windows Authentication.  Maybe Edge is using a different method.