Edge Beta status_access_violation

Copper Contributor

I've been using Edge Beta for some time now, and recently when I try to open my camera in google meet, it freezes, then says status_access_violation. I already tried the methods on google (disabling renderer code integrity, changing the file name, etc...) but it still doesn't work. I also noticed this issue is only present in Edge Beta, not in the stable version (I don't use Dev or Canary), please help.

1 Reply

I've had the same issue but for me in particular when I try and pull up steamcommunity.com/chat and sometimes Twitch if I've left it open in the background for too long, although after disabling a bunch of related extensions that hasn't happened recently just Steam.

I happened to catch it loading one day in DevTools and I saw something about friends.js being stalled and finally loading after 1 day (compared to everything else being 10-100ms) but I'm not sure how to debug this issue I keep trying all the built-in tools with no success as of yet, also tried the --disable-features=RendererCodeIntegrity which didn't seem to do anything.

If I take the time to attempt closing/reopening and refreshing the page, it usually eventually loads but it's very stubborn not to. Any ideas would be greatly appreciated as besides this issue Beta seems to run better for me and I was hoping not to have to update every hour with the others.


Edit: I gave up and downloaded Edge Dev and it actually has been performing even better than Beta, so I'll still try and find out why I was getting the STATUS_ACCESS_VIOLATION error in the first place but at least now I'm back to a normal functioning browser.