Dev channel update to 96.0.1032.0 is live


Hello Insiders!  Today we’re releasing build 96.0.1032.0 to the Dev channel.  In case you missed it last week, the new version of Edge is now officially available on Xbox!  You can read more here:  In what’s new and exciting this week: 


Added features: 


  • Added an item to the menu when right-clicking tabs that moves the tab to a different profile, even if no windows for that profile are currently open. 
  • Enabled voice typing in web pages on Windows 11. 
  • Added a button to the main feedback dialog to easily get to the “Recreate my problem” sub-dialog. 
  • Added an X to close certain toast notifications that appear when managing Collections.
  • Added a button to exit Immersive Reader on iPad.   
  • Added improved messaging when the Web Widget fails to open because an extension disabled it. 


Improved reliability: 


  • Fixed a crash when opening a window to a profile when a window for another profile is open. 
  • Fixed a crash when viewing Settings in a Guest window. 
  • Fixed a crash when using Internet Explorer mode. 
  • Mobile: 
    • Fixed a crash on Android when using third-party autofill providers. 
    • Fixed a crash on Android when downloading something. 
    • Fixed a crash on iPad. 
    • Fixed some crashes on Android 12. 
  • Fixed a crash in WebView2 apps when opening a context menu (Issue 1744). 


Changed behavior: 


  • Fixed an issue where enabling spellchecking for multiple languages resulted in only one language getting spellcheck results. 
  • Fixed an issue where opening a new window from the Favorites or History management pages fails. 
  • Fixed an issue where importing data from other browsers sometimes fails in certain languages. 
  • Fixed an issue where certain kinds of browser history are able to be deleted even when deleting history is disabled by management policy.
  • Fixed an issue where editing a text note in a Collection sometimes isn’t possible because the pane automatically scrolls to where the note isn’t visible. 
  • Fixed an issue where entering Kids mode unnecessarily adds badging to browser shortcuts. 
  • Fixed an issue where websites that ask for permission to use a 2-Factor Authentication device result in a blank permission dialog. 
  • Fixed an issue where setting a website installed as an app to run when the device starts up via the app’s post-install dialog isn’t reflected in the Apps management page. 
  • Fixed an issue where there is no indication that a download has started in websites installed as apps. 
  • Fixed an issue where clicking the button in Settings to restart the browser doesn’t actually restart it. 
  • Fixed an issue where input sometimes doesn’t work when mini menus are visible. 
  • Fixed an issue where the Web Widget doesn’t respond to touchscreen input. 
  • Fixed an issue on Xbox where the Setting to open a specific page on browser startup doesn’t work. 
  • Mobile: 
    • Fixed an issue where signing into the browser sometimes fails. 
    • Fixed an issue where signing into the browser sometimes fails after updating the app. 
    • Fixed an issue where company resources are sometimes blocked with a “You can’t get there from here” error even though the device and browser are signed into the company properly. 
    • Fixed an issue where setting the default search provider sometimes fails. 
    • Fixed an issue where certain websites can’t be logged into in InPrivate. 
    • Fixed an issue on Android 12 where autofill data save prompts sometimes don’t appear when they should. 
    • Fixed an issue where data is sometimes inadvertently imported from other browsers multiple times in a row, leading to duplicate data. 


Known issues: 


  • Users of certain ad blocking extensions may experience playback errors on YouTube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


As always, we couldn’t do this without you! 


28 Replies


Nice to read the whole bandwagon of shebang is moving ahead. Less nice is the miss of something, the big S for example:


Good news!! On Sep 06, 2021, you shared with us this feedback:
Request - How to change tabs name in Tab group Having vertical tab groups is godsend goody! But I[…]

We want to let you know that we fixed an issue that's related to this feedback in an upcoming update to Microsoft Edge.
Thank you for helping us make Microsoft Edge better than it was before. We can't wait to hear what you think of next!
The Microsoft Edge Team


Probably there's a grammatical bug - it should run "in an upcoming updates to Microsoft Edge".

Anyway, thanks for perpetually rekindling my hopes...


I'm liking these improvements, but what I'd really like to see fixed is notifications on Mac (Big Sur, 11.6). They stopped working many, many months ago and are a really critical part of the web experience. I've seen others report this issue, so I'm sure I'm not alone. I've confirmed that notifications are allowed for the site and in the system settings. I've previously have raised this through 'Send Feedback' but have had no response and find that this is still not working.

Pinned tabs not persisting across sessions is another ongoing issue (but I've given up on using them now!)
No idea if this is a new problem, but on a whim tried with this version to log in to my Duolingo ( account. Did not work: after logging (with google id) the start page is covered with a grey cast and inaccessible. I think this may be a question dialog that does not work on Edge, because when logging in with Chrome, I get the cast but also a dialog box ("Are you a teacher? ..."), and after dismissing it, the page is available. (OS: Fedora 33, XFCE desktop).
Edge Dev Version 96.0.1032.0 (Official build) dev (64-bit) ​crashes immediately if it tries to load saved payment information. The previous build didn't seem to have this bug, and Version 94.0.992.38 (Official build) (64-bit) does not crash either.
Hell, i have synchronisation problems since this update
Yeah! Send to device is finally working like a charme. I had given up on this feature, since it never worked reliably. But now with Edge Dev on Android and Desktop we can really use it - thank you :)

@MarkBarbieri Can you try a demo:


If it fails, navigate Edge to edge://push-internals. This is a diagnostic page that captures push messaging errors.  Please provide the contents of this page, although you can remove "Endpoint", "Device ID", and "Channel ID".  The last section about errors is most important.

@erkkiruohtula can you try a Guest window to see if it's just something wrong with your user data?  Or if that still doesn't work, a different channel of Edge to see if it's a recent problem?  

@abdelfattah this is a known issue, and luckily you can at least turn off the setting to save and fill payment information to prevent the crash while we're working on the fix.  

@josh_bodner The push demo gives me the prompt to allow notifications when I enable them on the page, but fails with a CORS error when I try to Send a Push (see attached)


edge://push-internals output also attached.  






@MarkBarbieri that might be a red herring.  I hadn't noticed when I sent it, but that demo site appears to be broken in general (it fails with that same error in every browser...)  If you have a site that you normally use that can send you notifications on-demand, could you get the same info when you see a failed notification from it?  Otherwise, how about a different demo site like  

This was notified on Oct 06 and it is now Oct 08 and it is still not fixed.
A pretty basic requirement to load saved payment information - how was the error introduced!
I have reverted to Edge when I want to buy anything

@josh_bodner OK, that site worked, but still no notification.  I tested that site on Windows (Edge Dev release) and I get notifications there, but not on the Mac.


Let me know if the attached is not enough info.


This is another simple one that works on Windows, but not Mac


Interestingly it doesn't add any output to edge://push-internals

It's been 5 days, still no update on android.

@josh_bodner, I have been running on Ubuntu 20.04 LTS for at least the last 6 months and it has been rock solid.  I am finding this 96.0.1032.0 release to be too unstable.  On quite a number of sites, I am getting a SIGILL error code displayed after about 2 seconds on the page and it will repeat on refresh.  I am running into this so frequently that I am going to have to abandon Edge until this is fixed as I am getting failures on too many sites.




Same issue as  @akrh125  on Fedora 34 with KDE 5.22.25 on X-org. Practically unusable on a high percentage of websites displaying the same error @akrh125 screenshotted.

@croxx5f and @akrh125 this wasn't just limited to Linux, and should have been fixed in the following Dev update.  Let me know if you're still seeing this!  

@MarkBarbieri sorry for the delayed response!  It's actually by design that that Bennish site doesn't output anything to push-internals.  There are multiple ways to show toast notifications, and Push is just one way of doing that.  Bennish doesn't use Push though, so between that and the output from push-internals, it looks like Push is working fine, and the problem is on the toast side.  


So, can you try that Bennish site again, and maybe also, and then afterwards, copy over the contents of edge://histograms/Notification (if you open that histogram page before doing the tests, make sure you refresh the histogram page after doing the tests).  Also, do you have Chrome on the machine, and can you see if Chrome is having the same problem?  Ideally, the same channel of Chrome as Edge?  

@josh_bodner Thanks, that makes sense, re: the toast vs push notification, although I would have thought both are valid approaches but yet I get neither, so for me there are issues with both toast and push.


Just for clarification, I do not receive any notifications from sites such as GMail, Youtube, (or any other site).  It's interesting that on it is not even possible to toggle on the 'Desktop Notification setting'. (See attachment).  Does the team know something about the lack of desktop notification support?


I will install Chrome and test it later today.


Checking edge://histograms/Notification, Bennish does not produce any output (as expected for toast notification) and attached is the output for a single push from