Dev channel update to 93.0.933.1 is live


Hello Insiders!  Today we’re releasing build 93.0.933.1 to the Dev channel.  It’s a light week this week because of the upcoming holiday in the US, but that just means that the following can be the star of the show… 

Those of you using Edge Mobile over the past few months may have noticed that Canary and Dev are now a) in existence, and b) mirroring the version number of their desktop counterparts.  We’re excited to announce that Beta now joins them, and for those of you on iOS, we also need to explain more about how to get Beta:  Android users can find Beta in the Play store alongside Canary and Dev. 


As for all that’s new in the browser: 


Added features: 


  • Enabled Tab Groups by default. 
  • Added the ability to add a Tab Group to a Collection and open the contents of a Collection in a Tab Group. 
  • Added a management policy to control which Internet Explorer Integration Cloud Site List to use.  Note that updates to administrative templates and documentation may not have occurred yet. 
  • Enabled by default access to hand tracking data in Web XR scenarios. 


Improved reliability: 


  • Fixed a crash when closing a tab. 
  • Fixed a crash when opening tabs. 
  • Fixed a crash when closing IE mode tabs. 
  • Fixed a crash on startup. 
  • Fixed a crash on Mac when using context menus in Collections. 
  • Fixed a crash when interacting with autofill popups. 
  • Fixed a crash when using the Find on Page bar. 
  • Fixed a crash when sending feedback. 
  • Fixed a crash when closing the Web Widget. 
  • Fixed a crash on Windows 7 when using PWAs. 


Changed behavior: 


  • Fixed an issue where the new tab page sometimes doesn’t load. 
  • Fixed an issue on Mac and Linux where Settings goes blank when searching for something. 
  • Fixed an issue where the Cookies and Site Data page in Settings is blank. 
  • Fixed an issue where passwords aren’t sorted properly in Settings. 
  • Fixed an issue where USB device permissions aren’t shown in the Site Information flyout. 
  • Fixed an issue where Collections don’t sync and are stuck in a “Syncing…” state. 
  • Fixed an issue where the Site Information dialog is too big. 
  • Fixed an issue where the Shopping flyout sometimes gets stuck and can’t be closed. 
  • Fixed an issue where the X to exit a fullscreen video sometimes doesn’t appear when it should. 
  • Fixed an issue where InPrivate is sometimes available when it shouldn’t be when using Family Safety. 
  • Fixed an issue where the button to exit Kids Mode doesn’t work. 
  • Fixed an issue where Price Comparison is triggered for trivial savings amounts. 
  • Fixed an issue where none of the UI is clickable in PWAs or websites installed as apps. 
  • Fixed an issue where the browser fails to close when clicking the Close button in the prompt to close all tabs when you close the browser if IE mode tabs are open. 
  • Fixed an issue where modal dialogs sometimes don’t display correctly when using IE mode tabs. 
  • Fixed an issue where devices running Windows 10 Pro for Workstations sometimes don’t get management policies applied correctly to them. 
  • Fixed an issue where improperly set management policies sometimes cause downloads to fail. 


Known issues: 


  • Certain extensions such as the Microsoft Editor extension don’t work on Linux.  As soon as they’re installed, they crash and are disabled.  We’re currently investigating. 
  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are still seeing favorites get duplicated.  This issue should be reduced now that automatic deduplication has been introduced into Insider channels, but we’re still rolling that out in Stable.  We’ve also seen duplication happen when running the manual deduplicator on multiple machines before either machine has a chance to fully sync its changes, so make sure to leave plenty of time in between runs of the deduplicator. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


Next week will be even lighter… because there will be no scheduled Dev release! 


29 Replies
On Linux (Fedora 33): edge://settings/passwords still empty. The entire screen is not empty. The left hand column listing the different settings is visible, but the area where the password info should appear is blank.

Added the ability to add a Tab Group to a Collection and open the contents of a Collection in a Tab Group. 

I have been waiting for this feature. This will make session management a lot more easier.

I am glad to join the Microsoft Edge insider since i using dev channel on PC. And i am happy the three channels join to mobile on Android.

But as you guys update the canary version on every day between PC as same as on Android, the version dev channel betwen PC and Android is not same, maybe late on more days or weeks.
For example, today, Edge dev channel on PC version number is 93.0.933.1, while on Android is 93.0.926.0

I know on Android need time because the play store verification, but i hope you can faster deliver the update and same version on dev channel, and also beta channel, as same as you did on canary channel.

I hope you hear my feedback.
thank you.

Hello, the Passwords page in Settings is still blank. This is on the Edge Dev Mac M1 version.
Thank you very much for your wonderful job, have a nice well holidays !
We made a fix for this that should have been in this week's build, but it appears that it didn't work, so I'll check on what the status of it is.
Why this is not released for mobile? Its not there in play or apk mirror.
I am curious too about that.




Still bug the black "F" letter, if used black theme. But, on GTK theme no bug. Ubuntu 21.04


@josh_bodner Any chance Microsoft Edge Dev Team fix this white flash issue when edge://flags/#enable-force-dark flags enabled ?


This another discussion thread


@BobD68 and @erkkiruohtula if you could go to the blank Settings page, hit F12, and tell me what error the Console is showing, the team says that would be a big help.  


Hi, I have been using Microsoft Edge on Ubuntu 18.04.5 LTS and have come to heavily rely on it as my organisation moved to M365.  I have updated to Version 93.0.933.1 (Official build) dev (64-bit).

However, the edge://settings/passwords are empty. The entire screen is not empty. The left-hand column listing the different settings is visible, but the area where the password info should appear is blank. I couldn't find a solution on the net. I have attached a screenshot. Please advice.

still waiting for Azure Active Directory Account feature sync across Linux and Windows.
I am glad to see that a number of users on different linux distros are having the same problem with the blank edge://settings/passwords page. I have the same issue on 3 Gentto based systems. I hope this gets fixed soon!
Tried it. Copy-paste:
assert.js:85 crbug/1173575, non-JS module files deprecated.
(anonymous) @ assert.js:85
util.js:320 crbug/1173575, non-JS module files deprecated.
(anonymous) @ util.js:320
promise_resolver.js:84 crbug/1173575, non-JS module files deprecated.
(anonymous) @ promise_resolver.js:84
icon.js:159 crbug/1173575, non-JS module files deprecated.
(anonymous) @ icon.js:159
ui.js:213 crbug/1173575, non-JS module files deprecated.
(anonymous) @ ui.js:213
keyboard_shortcut_list.js:94 crbug/1173575, non-JS module files deprecated.
(anonymous) @ keyboard_shortcut_list.js:94
command.js:1 Failed to load resource: net::ERR_FAILED
parse_html_subset.js:218 crbug/1173575, non-JS module files deprecated.
(anonymous) @ parse_html_subset.js:218
load_time_data.js:215 crbug/1173575, non-JS module files deprecated.
(anonymous) @ load_time_data.js:215
Hey, what about tab groups on mobile?

@erkkiruohtula Same issue on Ubuntu 20.04, Edge 93.0.933.1 (Official build) dev (64-bit). The password settings page is blank, but no errors in the console.



This build doesn't allow access to my modem settings (Huawei HG8145v5).
It gives an "ERR_CONNECTION_REFUSED" error message.
Both in my current profile, new profile, incognito mode and guest mode.
I tried in other browsers and devices, and in all if it lets access.
I even did a ping from CMD and everything works normal except for Edge.




Window 11 build 22000.65

MS Edge Dev build 93.0.933.1

I have been seeing similar results while testing some browser settings. ERR_CONNECTION_REFUSED seems or proceed some innerHTML behavior. I will update this discussion with further findings