Dev channel update to 93.0.910.5 is live


Hello Insiders!  Today we’re releasing build 93.0.910.5 to the Dev channel.  As you can see, this is the first 93, so we’re a little lighter this week than last when it comes to changes, but we’ve still got lots to talk about! 



Now, for this week’s notables:


Added features: 


  • Added a button on Mac that will directly appear on certain videos to let users enter Picture in Picture mode.
  • Added the ability on Mac to use fingerprint authentication to allow viewing or autofilling a password. 
  • Added the Share option to the … menu in PWAs and websites installed as apps. 
  • Improved inking latency. 


Improved reliability: 


  • Fixed a crash when navigating to a website. 
  • Fixed a crash when using the profile switcher in PWAs. 
  • Fixed a crash when using Google Meet. 


Changed behavior: 


  • Fixed an issue where certain Settings pages are blank. 
  • Fixed an issue where the Immersive Reader toolbar is sometimes blank. 
  • Fixed an issue where icons on the toolbar that have text bubbles on them, for example extension buttons, are clipped or only partially visible. 
  • Fixed an issue where pinning a website to the Taskbar sometimes fails. 
  • Fixed an issue where toast notifications from websites sometimes don’t appear. 
  • Fixed an issue where the Save/Save As buttons in the Downloads popup aren’t shown properly in certain languages. 
  • Fixed an issue on Mac where opening a new tab sometimes doesn’t scroll the vertical tabs pane to make the newly-opened tab visible. 
  • Fixed an issue where irrelevant data is saved by autofill. 
  • Fixed an issue where user-installed fonts sometimes aren’t displayed correctly. 
  • Fixed an issue where Guided Switch settings for specific websites sometimes aren’t respected. 
  • Disabled the ability to customize the site list for Guided Switch on devices that have Information Protection enforced since the functionality is broken in this scenario. 


Known issues: 


  • Certain extensions such as the Microsoft Editor extension don’t work on Linux.  As soon as they’re installed, they crash and are disabled.  We’re currently investigating. 
  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are still seeing favorites get duplicated.  This issue should be reduced now that automatic deduplication has been introduced into Insider channels, but we’re still rolling that out in Stable.  We’ve also seen duplication happen when running the manual deduplicator on multiple machines before either machine has a chance to fully sync its changes, so make sure to leave plenty of time in between runs of the deduplicator. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


Beta users, be on the lookout for version 92 to come to you soon! 


68 Replies
gentle reminder about the vertical tabs fitts' law issue (apologies if it's already being worked on). here is the discussion for it
Hey Josh, it’s been six months since I’ve mentioned here about translation issues, and they still haven’t been fixed. Actually, new ones showed up on desktop, and also in the mobile version with the new builds.



Are there any plans to fix the problem tabs showing up as File Explorer icons on the task bar?  It's been reported for months.


I've attached an example of it.

@josh_bodner On this version, the 3-dot menu and other menus are too bing and looks like ugly, have a bad sense after enabled Reload website in IE mode.



2021-06-10 (2).png

2021-06-10 (3).png


and this is Edge Stable 91: 

2021-06-10 (4).png

2021-06-10 (5).png

2021-06-10 (6).png



This issue of extension icons/badges being cut off is still not fixed in the new update. Any idea when it will be resolved?

@NashizM It's fixed for me, at least.

just got another update, fixed now as well.
It's fixed for me too.
Hello, but where can I get Edge Dev macOS version please?
you can visit to download Edge Dev for macOS.
Thank you
Running the newest Edge Dev M1 build. Nice. Took about 15 min for all my sync settings to migrate. But it's now been 30 min and when I click to go to Passwords in Settings that screen is blank. Totally blank. I am thinking that is taking more time to sync....
Will the new font rendering also apply to viewing PDFs in Edge? Thanks.
Darn, hours later and my passwords screen in Settings is blank still. I have been a long time Edge Dev user on the Windows side and it's always been great, no crashes or weirdness.


On Linux, edge://settings/passwords shows blank page when there is saved passwords. New profile having no saved passwords doesn't have this issue. Maybe macOS as well. This is new bug on 93.0.910.5 except on Windows.


This error was fixed for me. The full bubble number is no showing complete.

I'm getting a lot more pages that hang at one core's worth of full CPU usage, and continuously increasing RAM usage. I eventually get a frozen tab pop-up with the option to kill it or wait, and then RESULT_CODE_HUNG. It crashes differently if I let it gobble up all 20GB of RAM.

Had it start happening with YouTube, but only when I try to play a video, even though I was mostly free of the issues people were having before. Disabled all of the usual suspects (Enhancer for YouTube, uBlock Origin, Privacy Badger) and still had it happen.

It happens on seemingly random sites too, like

Only started with the 93.0.910.5 update, or it could have been 21H1 this morning for all I know.

It seemingly stopped happening with YouTube after doing exactly one Ctrl+Win+Shift+B (thanks AMD!) so that may have been the same video issue from before, but it still happens with other sites. Plus, my video driver version didn't change before/after this, and the Radeon software still says I am up to date on 21.5.2 from May 11th.

@abdelfattah Oh I'm glad to know it's not just me. I've been having problems with playing YouTube videos. It hangs the whole browser and then I have to quit out of Edge. I'm going to have to use Safari until this gets fixed. Edge Dev 93.0.910.5 on macOS Big Sur 11.4 


Edit: This isn't just happening with YouTube. A bunch of sites seem to hang in Edge. I went to the Microsoft 365 admin portal and I can't do almost anything there without Edge freezing up. This wasn't happening until this update.

New problem. When I pull up the Settings page and type anything into the search settings box the whole page goes blank. Unable to search anything in settings.