SOLVED

Default PDF viewer / System Viewer

%3CLINGO-SUB%20id%3D%22lingo-sub-2360094%22%20slang%3D%22en-US%22%3EDefault%20PDF%20viewer%20%2F%20System%20Viewer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2360094%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22c01162%22%3E%3CDIV%20class%3D%22c01164%22%3E%3CSPAN%20class%3D%22c01166%22%3EVersion%2090.0.818.56%20(Official%20build)%20(64-bit)%3C%2FSPAN%3E%3CDIV%20class%3D%22c01173%22%3E%3CDIV%20class%3D%22c01282%20%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c01284%22%3E%3CSTRONG%3EThe%20way%20Edge%20Chromium%20handles%20downloaded%20.pdf%20files%20has%20bugged%20me%20ever%20since%20it%20was%20released%20and%20is%20still%20not%20working%20properly.%3C%2FSTRONG%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01284%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c01284%22%3EMy%20System%20Viewer%20(default%20Windows%20application%20for%20.pdf%20files)%20is%20set%20to%20Foxit%20PhantomPDF%20as%20you%20can%20see%20here%3A%3C%2FDIV%3E%3CDIV%20class%3D%22c01284%22%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Picture1.jpg%22%20style%3D%22width%3A%20503px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281012i403C31D05977E6D7%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Picture1.jpg%22%20alt%3D%22Picture1.jpg%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Picture2.jpg%22%20style%3D%22width%3A%20440px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281013i875C3CDCC2432604%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Picture2.jpg%22%20alt%3D%22Picture2.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01170%22%3E%3CDIV%3E%3CDIV%20class%3D%22c01200%22%3E%3CDIV%20class%3D%22c01171%20c01216%22%3E%3CDIV%20class%3D%22c01217%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c01217%22%3EWhen%20I%20download%20a%20.pdf%20file%20in%20Edge%20you%20can%20also%20see%20the%20Foxit%20icon%20next%20to%20the%20file%3A%3C%2FDIV%3E%3CDIV%20class%3D%22c01217%22%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Picture3.jpg%22%20style%3D%22width%3A%20491px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281014i590904190A549D02%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Picture3.jpg%22%20alt%3D%22Picture3.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3EHowever%2C%20when%20I%20click%20%22Open%20file%22%20it%20opens%20as%20a%20new%20Tab%20in%20Edge%20and%20NOT%20in%20Foxit%20Phantom%3A%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Picture4.jpg%22%20style%3D%22width%3A%20680px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281015iE3FF5A22A8A05B58%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Picture4.jpg%22%20alt%3D%22Picture4.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3EThis%20happens%20regardless%20of%20how%20the%20option%20%22Always%20open%20with%20system%20viewer%22%20is%20set%2C%20i.e.%20both%20when%20it%20is%20OFF%20and%20ON%3A%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Picture5.jpg%22%20style%3D%22width%3A%20450px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281016i6C02028E8BB2CEB4%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Picture5.jpg%22%20alt%3D%22Picture5.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3EIn%20older%20versions%20(up%20to%2089.0.774.75%20(Official%20build)%20(64-bit))%20it%20was%20possible%20to%20right%20click%20and%20then%20choose%20%E2%80%9COpen%20with%20System%20Viewer%E2%80%9D%20manually.%20Not%20ideal%20but%20a%20workaround%20nonetheless%3A%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Picture6.jpg%22%20style%3D%22width%3A%20726px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281019iE00D226CE6E31EC6%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Picture6.jpg%22%20alt%3D%22Picture6.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01221%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWith%20the%20latest%20version%20the%20only%20option%20is%20to%20click%20on%20%E2%80%9CShow%20in%20folder%E2%80%9D%20and%20then%20open%20the%20default%20.pdf%20via%20Windows%20Explorer%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Picture7.jpg%22%20style%3D%22width%3A%20455px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F281020i9BCB72DF36C9A4DB%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Picture7.jpg%22%20alt%3D%22Picture7.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2360142%22%20slang%3D%22en-US%22%3ERe%3A%20Default%20PDF%20viewer%20%2F%20System%20Viewer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2360142%22%20slang%3D%22en-US%22%3EReply%20to%20self.%3CBR%20%2F%3EI%20just%20got%20Version%2090.0.818.62%20(Official%20build)%20(64-bit)%20and%20this%20has%20finally%20been%20fixed.%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2360146%22%20slang%3D%22en-US%22%3ERe%3A%20Default%20PDF%20viewer%20%2F%20System%20Viewer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2360146%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1055508%22%20target%3D%22_blank%22%3E%40Pellique%3C%2FA%3E%20%2C%3CBR%20%2F%3E%3CBR%20%2F%3E%22I%20just%20got%20Version%2090.0.818.62%20(Official%20build)%20(64-bit)%20and%20this%20has%20finally%20been%20fixed.%22%20so%20your%20problem%20is%20solved%3F%20xD%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20so%20you%20can%20mark%20your%20answer%20as%20solved%20%3BD%3CBR%20%2F%3E%3CBR%20%2F%3EBest%20regards%2C%3CBR%20%2F%3ESchnittlauch%3CBR%20%2F%3E%3CBR%20%2F%3E%22First%2C%20No%20system%20is%20safe.%20Second%2C%20Aim%20for%20the%20impossible.%20Third%20no%20Backup%2C%20no%20Mercy%22%20-%20Schnittlauch%3CBR%20%2F%3E%3CBR%20%2F%3EMy%20answer%20helped%20you%3F%20Don't%20forget%20to%20leave%20a%20like.%20Also%20mark%20the%20answer%20as%20solved%20when%20your%20problem%20is%20solved.%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2360182%22%20slang%3D%22en-US%22%3ERe%3A%20Default%20PDF%20viewer%20%2F%20System%20Viewer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2360182%22%20slang%3D%22en-US%22%3EI%20can't%20find%20a%20way%20to%20mark%20as%20solved.%3C%2FLINGO-BODY%3E
New Contributor
Version 90.0.818.56 (Official build) (64-bit)
 
The way Edge Chromium handles downloaded .pdf files has bugged me ever since it was released and is still not working properly.
 
My System Viewer (default Windows application for .pdf files) is set to Foxit PhantomPDF as you can see here:
Picture1.jpgPicture2.jpg
 
When I download a .pdf file in Edge you can also see the Foxit icon next to the file:
Picture3.jpg
 
However, when I click "Open file" it opens as a new Tab in Edge and NOT in Foxit Phantom:
Picture4.jpg
 
This happens regardless of how the option "Always open with system viewer" is set, i.e. both when it is OFF and ON:
Picture5.jpg
 
In older versions (up to 89.0.774.75 (Official build) (64-bit)) it was possible to right click and then choose “Open with System Viewer” manually. Not ideal but a workaround nonetheless:
Picture6.jpg

 

With the latest version the only option is to click on “Show in folder” and then open the default .pdf via Windows Explorer:

Picture7.jpg

4 Replies
best response confirmed by Pellique (New Contributor)
Solution
Reply to self.
I just got Version 90.0.818.62 (Official build) (64-bit) and this has finally been fixed.
Hi @Pellique ,

"I just got Version 90.0.818.62 (Official build) (64-bit) and this has finally been fixed." so your problem is solved? xD

If so you can mark your answer as solved ;D

Best regards,
Schnittlauch

"First, No system is safe. Second, Aim for the impossible. Third no Backup, no Mercy" - Schnittlauch

My answer helped you? Don't forget to leave a like. Also mark the answer as solved when your problem is solved. :)
I can't find a way to mark as solved.
You should be able to see a "mark as best answer" button under each comment :)

https://techcommunity.microsoft.com/t5/tech-community-blog/a-guide-to-using-the-best-response-featur...