Cannot Login with Office 365 Work Account to Edge Profile

Occasional Contributor

I got a user that is not able to login to Edge with his Office 365 work account. 


Current build is "Version 80.0.334.2 (Offizielles Build) dev (64-Bit)" but he has this issue since we tried with the official release candidate approx. 2 weeks ago. We tried to uninstall Edge and reinstall it with different versions. We cleared all AppData files related to Edge after uninstall. All versions seem to have this issue related to this user. 


For screenshot see attached file. Translated to English it means something like "Action required" - "Hmm... we got problems validating your account". 


When I create a second profile and try to log in with my account it works fine. Seems to be account related. 


The account of that user is Azure AD based and has full Office 365 E3 license. The account works fine with all O365 services. He can login to within edge without any issues. It is just the profile in edge that seems to hate his user. 


Any ideas? OS is Windows 7 at this point.

4 Replies
I used to get the same error, on Windows 10 latest ver. I have Office365 business premium with E5. does that user account have self service password reset enabled for it? it could be related to 2FA or MFA.
in my case that user account was connected to Windows 10 using AAD from the start but I don't remember how it works in Windows 7.


Thank you for your reply. 

The user is not enabled for self service password reset (as all of our users are not). 

We do not use 2FA/MFA. He just needs his User Principal Name (same as his mail address) and his password. 

I was at his desk to check what he is doing. I can confirm that he knows his password and can login to within Edge browser without problems. When we try to log hin in in his browser profile the login seems to fail as the browser shows "action required" at his profile. 


Sounds confusing, I know. 

Is it the only user account that has this problem?
if other users are experiencing the same problem, are they also on Windows 7?
if it's possible, could you temporary enable self service password reset for that account and see if it changes anything?

P.S, probably not related to your issue but there is this article
that talks about syncing data in work accounts and it appears that Enterprise State Roaming is required for it.
We are testing Edge Chromium with a small group of people (8-10) to validate compatibility with our intranet sites and find issues that could occur.

It is a single user facing this problem. Other Win 7 users do not have this issue. As I can login to his Edge with my account (new profile) it seems to be User Account related.

Have enabled self service password reset for a group he is member of. Have contacted him and will give feedback when he has tested. Thank you for this suggestion.

Had a consultation with our Azure AD team. Enterprise State Roaming is not enabled at this point. They didn't want to enable it at this point.