blank page edge://settings/passwords

%3CLINGO-SUB%20id%3D%22lingo-sub-2529004%22%20slang%3D%22en-US%22%3Eblank%20page%20edge%3A%2F%2Fsettings%2Fpasswords%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2529004%22%20slang%3D%22en-US%22%3E%3CP%3E%3CBR%20%2F%3EMicrosoft%20Edge%3CBR%20%2F%3EVersion%2093.0.933.1%20(Official%20build)%20dev%20(64-bit)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOS%20%3A%26nbsp%3BRelease%20Linux%20Mint%2020%20Ulyana%2064-bit%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIssue%20%3A%26nbsp%3Bblank%20page%3A%26nbsp%3B%20edge%3A%2F%2Fsettings%2Fpasswords%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnybody%20got%20any%20clue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2529004%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EEdge%2093%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELinuxmint%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2551672%22%20slang%3D%22en-US%22%3ERe%3A%20blank%20page%20edge%3A%2F%2Fsettings%2Fpasswords%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2551672%22%20slang%3D%22en-US%22%3ESame%20issue%20happening%20for%20me.%20Other%20settings%20page%20are%20loading%20fine.%3CBR%20%2F%3E%3CBR%20%2F%3EVersion%2093.0.926.1%20(Official%20build)%20dev%20(64-bit)%3CBR%20%2F%3E%3CBR%20%2F%3EOS%3A%20Centos%208%2064-bit%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2573716%22%20slang%3D%22en-US%22%3ERe%3A%20blank%20page%20edge%3A%2F%2Fsettings%2Fpasswords%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2573716%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20on%20Ubuntu%2020.04.%20Just%20a%20guess%2C%20but%20I%20suspect%20they%20are%20probably%20trying%20to%20hook%20into%20the%20Windows%20Hello%20security%20system%2C%20which%20obviously%20doesn't%20work%20on%20Linux.%20Chrome%20seems%20to%20manage%20ok%20so%20they%20will%20likely%20get%20there%20eventually.%20It%20only%20seems%20to%20happen%20when%20there%20are%20passwords%2C%20though%20happens%20both%20for%20connected%20and%20non%20connected%20profiles.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3E(anonymous)%20%40%20settings.bundle.js%3A1%0Apasswords%3A1%20Error%20handling%20response%3A%20TypeError%3A%20Cannot%20read%20properties%20of%20undefined%20(reading%20'value')%0Aat%20IC.isPasswordVulnerable%20(edge%3A%2F%2Fsettings%2Fsettings.bundle.js%3A1%3A1145028)%0Aat%20edge%3A%2F%2Fsettings%2Fsettings.bundle.js%3A1%3A1173262%0Aat%20Array.map%20(%3CANONYMOUS%3E)%0Aat%20IC.mapUiEntryWithPasswordToTableData%20(edge%3A%2F%2Fsettings%2Fsettings.bundle.js%3A1%3A1172399)%0Aat%20IC.renderTableSubLabel%20(edge%3A%2F%2Fsettings%2Fsettings.bundle.js%3A1%3A1156438)%0Aat%20IC.render%20(edge%3A%2F%2Fsettings%2Fsettings.bundle.js%3A1%3A1170840)%0Aat%20Ha%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A70074)%0Aat%20Ua%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A69869)%0Aat%20ku%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A105483)%0Aat%20ml%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A96924)%0Aat%20vl%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A96849)%0Aat%20ul%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A93879)%0Aat%20edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A45520%0Aat%20e.unstable_runWithPriority%20(edge%3A%2F%2Fsettings%2Flib_common.chunk.js%3A1958%3A3844)%0Aat%20Bi%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A45229)%0Aat%20Yi%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A45465)%0Aat%20qi%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A45400)%0Aat%20ll%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A9%3A94170)%0Aat%20Object.notify%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A17%3A3696)%0Aat%20e.t.notifyNestedSubs%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A17%3A3270)%0Aat%20e.t.handleChangeWrapper%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A17%3A3338)%0Aat%20g%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A25%3A8913)%0Aat%20edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A25%3A6386%0Aat%20dispatch%20(edge%3A%2F%2Fsettings%2Flib_react.chunk.js%3A25%3A12651)%0Aat%20edge%3A%2F%2Fsettings%2Fsettings.bundle.js%3A1%3A2634607%3C%2FANONYMOUS%3E%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2577824%22%20slang%3D%22en-US%22%3ERe%3A%20blank%20page%20edge%3A%2F%2Fsettings%2Fpasswords%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2577824%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20same%20thing%20happens%20after%20I%20update%20to%20v%3CSPAN%3E92.0.902.55%20on%20MacOS%20Big%20Sur%2C%20not%20only%20that%2C%20searching%20something%20in%20the%20settings%20can%20also%20result%20in%20the%20same%20thing.%20I%20already%20feedback%20about%20this%20issue%20before%2C%20it%20seems%20like%20the%20edge%20team%20didn't%20fix%20anything.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2596732%22%20slang%3D%22en-US%22%3ERe%3A%20blank%20page%20edge%3A%2F%2Fsettings%2Fpasswords%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2596732%22%20slang%3D%22en-US%22%3ESame%20issue%20here%20since%20last%202%20versions%20but%20Microsoft%20team%20havent%20fixed%20it%20yet.%3CBR%20%2F%3E%3CBR%20%2F%3EAlso%20the%20websites%20are%20taking%20forever%20to%20load%20on%20Latest%20MacOs%20Monterey%20Beta%3CBR%20%2F%3E%3CBR%20%2F%3EBefore%20every%20page%2C%20request%20data%20is%20being%20sent%20to%20events.data%20to%20microsoft%2C%20even%20though%20i%20have%20disabled%20usage%20tracking.%20This%20is%20serious%20privacy%20issue%20in%20edge%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2597082%22%20slang%3D%22en-US%22%3ERe%3A%20blank%20page%20edge%3A%2F%2Fsettings%2Fpasswords%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2597082%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1116984%22%20target%3D%22_blank%22%3E%40besloi%3C%2FA%3E%26nbsp%3BThank%20you%20for%20the%20info.%20I've%20been%20wondering%20why%20loading%20is%20so%20slow%20on%20macOS%20Monterey%2C%20now%20I%20know%20that%20I'm%20not%20alone.%20I'm%20using%20v92%2C%20Edge%20v91%20seems%20to%20work%20fine.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor


Microsoft Edge
Version 93.0.933.1 (Official build) dev (64-bit)

 

OS : Release Linux Mint 20 Ulyana 64-bit

 

Issue : blank page:  edge://settings/passwords 

 

Anybody got any clue?

10 Replies
Same issue happening for me. Other settings page are loading fine.

Version 93.0.926.1 (Official build) dev (64-bit)

OS: Centos 8 64-bit

Same on Ubuntu 20.04. Just a guess, but I suspect they are probably trying to hook into the Windows Hello security system, which obviously doesn't work on Linux. Chrome seems to manage ok so they will likely get there eventually. It only seems to happen when there are passwords, though happens both for connected and non connected profiles.

 

 

(anonymous) @ settings.bundle.js:1
passwords:1 Error handling response: TypeError: Cannot read properties of undefined (reading 'value')
at IC.isPasswordVulnerable (edge://settings/settings.bundle.js:1:1145028)
at edge://settings/settings.bundle.js:1:1173262
at Array.map (<anonymous>)
at IC.mapUiEntryWithPasswordToTableData (edge://settings/settings.bundle.js:1:1172399)
at IC.renderTableSubLabel (edge://settings/settings.bundle.js:1:1156438)
at IC.render (edge://settings/settings.bundle.js:1:1170840)
at Ha (edge://settings/lib_react.chunk.js:9:70074)
at Ua (edge://settings/lib_react.chunk.js:9:69869)
at ku (edge://settings/lib_react.chunk.js:9:105483)
at ml (edge://settings/lib_react.chunk.js:9:96924)
at vl (edge://settings/lib_react.chunk.js:9:96849)
at ul (edge://settings/lib_react.chunk.js:9:93879)
at edge://settings/lib_react.chunk.js:9:45520
at e.unstable_runWithPriority (edge://settings/lib_common.chunk.js:1958:3844)
at Bi (edge://settings/lib_react.chunk.js:9:45229)
at Yi (edge://settings/lib_react.chunk.js:9:45465)
at qi (edge://settings/lib_react.chunk.js:9:45400)
at ll (edge://settings/lib_react.chunk.js:9:94170)
at Object.notify (edge://settings/lib_react.chunk.js:17:3696)
at e.t.notifyNestedSubs (edge://settings/lib_react.chunk.js:17:3270)
at e.t.handleChangeWrapper (edge://settings/lib_react.chunk.js:17:3338)
at g (edge://settings/lib_react.chunk.js:25:8913)
at edge://settings/lib_react.chunk.js:25:6386
at dispatch (edge://settings/lib_react.chunk.js:25:12651)
at edge://settings/settings.bundle.js:1:2634607

 

The same thing happens after I update to v92.0.902.55 on MacOS Big Sur, not only that, searching something in the settings can also result in the same thing. I already feedback about this issue before, it seems like the edge team didn't fix anything.

Same issue here since last 2 versions but Microsoft team havent fixed it yet.

Also the websites are taking forever to load on Latest MacOs Monterey Beta

Before every page, request data is being sent to events.data to microsoft, even though i have disabled usage tracking. This is serious privacy issue in edge

@besloi Thank you for the info. I've been wondering why loading is so slow on macOS Monterey, now I know that I'm not alone. I'm using v92, Edge v91 seems to work fine.

@Faizulkiffli 

I have been using Edge dev build on a couple of my Linux systems, all Gentoo installs.  I have been very happy with Edge, having used both Chrome and Firefox prior to the swap.  However, for several dev versions over the last, approximately, two months the password settings page has not been working properly. I have read several posts that indicate that this issue is present on several Linux distributions. I have submitted feedback from all my systems for every non-working version in the hope the data would lead to a fix.

 

Today I updated to v93.0.961.10 dev and still the same problem. I cannot understand why this is not a major issue. On a fresh Edge install (delete the profile) the password setting page is displayed, but as soon as I sign in and the sync starts the password page is not displayed.  

 

Mike 

 

Error loading the password setting page: 

 

 

command.js:1 Failed to load resource: net::ERR_FAILED 
assert.js:85 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ assert.js:85 
util.js:320 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ util.js:320 
promise_resolver.js:84 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ promise_resolver.js:84 
icon.js:159 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ icon.js:159 
ui.js:213 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ ui.js:213 
keyboard_shortcut_list.js:94 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ keyboard_shortcut_list.js:94 
parse_html_subset.js:218 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ parse_html_subset.js:218 
load_time_data.js:215 crbug/1173575, non-JS module files deprecated. 
(anonymous) @ load_time_data.js:215 
lib_react.chunk.js:9 TypeError: Cannot read property 'value' of undefined 
at Uu.isPasswordVulnerable (settings.bundle.js:1) 
at settings.bundle.js:1 
at Array.map (<anonymous>) 
at Uu.mapUiEntryWithPasswordToTableData (settings.bundle.js:1) 
at Uu.<anonymous> (settings.bundle.js:1) 
at Uu.getFilteredSavedTableData (lib_common.chunk.js:25) 
at Uu.sortTableData (settings.bundle.js:1) 
at Uu.renderSavedPasswordsTable (settings.bundle.js:1) 
at Uu.render (settings.bundle.js:1) 
at Ha (lib_react.chunk.js:9) 
at Ua (lib_react.chunk.js:9) 
at ku (lib_react.chunk.js:9) 
at ml (lib_react.chunk.js:9) 
at vl (lib_react.chunk.js:9) 
at ul (lib_react.chunk.js:9) 
at lib_react.chunk.js:9 
at t.unstable_runWithPriority (lib_common.chunk.js:38) 
at Bi (lib_react.chunk.js:9) 
at Yi (lib_react.chunk.js:9) 
at qi (lib_react.chunk.js:9) 
at j (lib_react.chunk.js:9) 
at Yt (lib_react.chunk.js:9) 
iu @ lib_react.chunk.js:9 
lib_react.chunk.js:9 Uncaught TypeError: Cannot read property 'value' of undefined 
at Uu.isPasswordVulnerable (settings.bundle.js:1) 
at settings.bundle.js:1 
at Array.map (<anonymous>) 
at Uu.mapUiEntryWithPasswordToTableData (settings.bundle.js:1) 
at Uu.<anonymous> (settings.bundle.js:1) 
at Uu.getFilteredSavedTableData (lib_common.chunk.js:25) 
at Uu.sortTableData (settings.bundle.js:1) 
at Uu.renderSavedPasswordsTable (settings.bundle.js:1) 
at Uu.render (settings.bundle.js:1) 
at Ha (lib_react.chunk.js:9) 
at Ua (lib_react.chunk.js:9) 
at ku (lib_react.chunk.js:9) 
at ml (lib_react.chunk.js:9) 
at vl (lib_react.chunk.js:9) 
at ul (lib_react.chunk.js:9) 
at lib_react.chunk.js:9 
at t.unstable_runWithPriority (lib_common.chunk.js:38) 
at Bi (lib_react.chunk.js:9) 
at Yi (lib_react.chunk.js:9) 
at qi (lib_react.chunk.js:9) 
at j (lib_react.chunk.js:9) 
at Yt (lib_react.chunk.js:9)  

 

 

 

Just updated to 94.0.972.0 - password settings is fixed!

same to me

version:
Version 92.0.902.67 (Official build) (arm64)

 

yinheli_0-1628333784798.png

 

Same for me;
Version 92.0.902.67 (Official build) (arm64); mac os big sur 11.15.1

also any search query leads to blank page until i refresh it (cmd + r, for example);

https://imgur.com/a/shCQWDf screenshot.
(Finally) fixed for me on 94.x also, it is almost at feature parity with Chrome now!