Black screen issue when streaming/cast finally solved for Amazon Prime, Netflix...

Frequent Contributor

Hey folks, 
like many others I also experienced the issue of broken video streams and black screen phenomena when trying to cast (especially Chromecast) Amazon Prime, Netflix etc. on all the different Edge branches. 

 

The only known workaround was turning off hardware acceleration, but I wasn't willing to accept, especially since Chrome has no issues with streaming/casting when acceleration is on.

Well, after a lot of experimenting with different Edge flags, graphic driver setups, installing video codecs and so on, I finally found the solution. Researching how these streaming vendors manage DRM did the trick and the fix is so simple that I almost couldn't believe, lol 

 

So in short, here's how to solve broken streams and black screen casts on Edge with hardware acceleration enabled (at least it worked for me): 

Go to edge://flags/#edge-playready-drm-win10 set it to "Disabled", restart and enjoy your streams :)

 

Background: The big streaming vendors all use DRM (Digital Rights Management) to control how their content is shown, especially in context with user rights (e.g. the limitation to only watch the same video on Amazon Prime simultaneously on not more than 2 different devices). 

Now most of the streaming platforms are optimized to use Google's Widevine DRM technology, whereas Edge also supports Microsoft's PlayReady DRM by default (on Windows 10/11). But since it's not well implemented on many streaming platforms they struggle and give you all the above issues. 

That's why turning off hardware acceleration also can solve the problem, because this disables a lot of DRM features as well. 

So turning off PlayReady makes Edge using Widevine exclusively and the issues are gone. 

 

The only downside is that this will break 4k streaming, since it depends on PlayReady, but I can easily live with that, haha.

 

1 Reply

@Neon01 Thank you! I was trying to find the right setting to change for a couple weeks! Finally I searched the problem, found your blog and it worked! Thank you.