Home

Authentication issue

%3CLINGO-SUB%20id%3D%22lingo-sub-965212%22%20slang%3D%22en-US%22%3EAuthentication%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-965212%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ein%20previous%20builds%20this%20issue%20was%20resolved%20but%20it%20came%20back%201%20build%20ago.%3C%2FP%3E%3CP%3ESince%20i%20have%20edge%20dev%20as%20default%20browser%20everytime%20i%20click%20a%20link%20from%20OTRS%20(Apache%2F2.2.15%20(Linux%2FSUSE))%20i%20get%20this%20error%3A%3C%2FP%3E%3CP%3EAuthentication%20required!%3CBR%20%2F%3EThis%20server%20could%20not%20verify%20that%20you%20are%20authorized%20to%20access%20the%20URL%20%22%2Fotrs%2Findex.pl%22.%20You%20either%20supplied%20the%20wrong%20credentials%20(e.g.%2C%20bad%20password)%2C%20or%20your%20browser%20doesn't%20understand%20how%20to%20supply%20the%20credentials%20required.%3C%2FP%3E%3CP%3EIn%20case%20you%20are%20allowed%20to%20request%20the%20document%2C%20please%20check%20your%20user-id%20and%20password%20and%20try%20again.%3C%2FP%3E%3CP%3EIf%20you%20think%20this%20is%20a%20server%20error%2C%20please%20contact%20the%20webmaster.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOTRS%20is%20an%26nbsp%3BOpen%20Source%20Trouble%20Ticket%20System%20based%20on%20linux.%3C%2FP%3E%3CP%3EThe%20issue%20must%20be%20related%20to%20AD%20authentication%20being%20passed%20to%20the%20browser%20or%20something%20around%20this%20subject.%3C%2FP%3E%3CP%3EThank%20you%20for%20your%20support.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-990080%22%20slang%3D%22en-US%22%3ERe%3A%20Authentication%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-990080%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F436177%22%20target%3D%22_blank%22%3E%40ricardoruivo%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI'm%20sorry%20to%20hear%20you're%20running%20into%20this.%20Could%20you%20share%20what%20version%20of%20Edge%20dev%20you're%20using%20by%20navigating%20to%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fsettings%2Fhelp%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fsettings%2Fhelp%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAdditionally%2C%20you%20could%20try%20the%20next%20workaround%20and%20see%20if%20that%20fixes%20your%20issue%3A%3C%2FP%3E%0A%3CP%3E1.%20On%20a%20tab%2C%20navigate%20to%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%23edge-identity-based-http-auth%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fflags%2F%23edge-identity-based-http-auth%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E2.%20Set%20the%20flag%20for%26nbsp%3B%3CEM%3E%3CSPAN%3ESign%20in%20to%20intranet%20websites%20with%20your%20profile.%3C%2FSPAN%3E%3C%2FEM%3E%26nbsp%3Bto%20disabled%3C%2FP%3E%0A%3CP%3E3.%20Restart%20the%20browser%20for%20changes%20to%20take%20effect%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ELet%20me%20know%20if%20that%20solves%20your%20issue.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-995051%22%20slang%3D%22en-US%22%3ERe%3A%20Authentication%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-995051%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F404881%22%20target%3D%22_blank%22%3E%40DavidD95%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethanks%20for%20your%20help%20but%20did%20not%20resolve%20my%20issues.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eedge%20dev%20version%3A%26nbsp%3BVers%C3%A3o%2080.0.320.5%20(Compila%C3%A7%C3%A3o%20oficial)%20dev%20(64%20bits)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20not%20find%20the%20%22edge%3A%2F%2Fflags%2F%23edge-identity-based-http-auth%22%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-995062%22%20slang%3D%22en-US%22%3ERe%3A%20Authentication%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-995062%22%20slang%3D%22en-US%22%3Ewith%20the%20same%20url%3A%3CBR%20%2F%3Eie%2011.1069.171.34.0%20works%3CBR%20%2F%3EChrome%2078.0.3904.97%20(64%20bits)%3CBR%20%2F%3Ealso%20works%20%3B)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1009272%22%20slang%3D%22en-US%22%3ERe%3A%20Authentication%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1009272%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F436177%22%20target%3D%22_blank%22%3E%40ricardoruivo%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWe%20have%20deployed%20a%20fix%20that%20landed%20in%20Edge%20Canary%20and%20should%20be%20included%20in%20the%20next%20Dev%20update%20after%20current%2080.0.320.5%20build.%20This%20fix%20was%20also%20patched%20for%20current%20Edge%20Beta.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou%20should%20no%20longer%20see%20the%20issue%20on%20next%20Dev%20update.%20To%20confirm%20the%20fix%20works%20for%20you%2C%20you%20could%20try%20your%20scenario%20on%20Edge%20Canary%20or%20Edge%20Beta%20if%20you%20like.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ELet%20me%20know%20if%20you%20still%20run%20into%20any%20issue.%3C%2FP%3E%0A%3CP%3EThanks%20for%20reaching%20out%2C%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1022374%22%20slang%3D%22en-US%22%3ERe%3A%20Authentication%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1022374%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F404881%22%20target%3D%22_blank%22%3E%40DavidD95%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ejust%20got%26nbsp%3BThis%20is%20Dev%20Build%2080.0.334.2%20and%20the%20problem%20is%20solved!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMany%20thanks%2C%20keep%20up%20the%20good%20work.%3C%2FP%3E%3C%2FLINGO-BODY%3E
ricardoruivo
New Contributor

Hi,

 

in previous builds this issue was resolved but it came back 1 build ago.

Since i have edge dev as default browser everytime i click a link from OTRS (Apache/2.2.15 (Linux/SUSE)) i get this error:

Authentication required!
This server could not verify that you are authorized to access the URL "/otrs/index.pl". You either supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

In case you are allowed to request the document, please check your user-id and password and try again.

If you think this is a server error, please contact the webmaster.

 

OTRS is an Open Source Trouble Ticket System based on linux.

The issue must be related to AD authentication being passed to the browser or something around this subject.

Thank you for your support.

5 Replies
Highlighted

Hi @ricardoruivo 

 

I'm sorry to hear you're running into this. Could you share what version of Edge dev you're using by navigating to edge://settings/help

 

Additionally, you could try the next workaround and see if that fixes your issue:

1. On a tab, navigate to edge://flags/#edge-identity-based-http-auth

2. Set the flag for Sign in to intranet websites with your profile. to disabled

3. Restart the browser for changes to take effect

 

Let me know if that solves your issue.

 

Highlighted

@DavidD95 

 

hi,

 

thanks for your help but did not resolve my issues.

 

edge dev version: Versão 80.0.320.5 (Compilação oficial) dev (64 bits)

 

Could not find the "edge://flags/#edge-identity-based-http-auth"

Highlighted
with the same url:
ie 11.1069.171.34.0 works
Chrome 78.0.3904.97 (64 bits)
also works ;)
Highlighted

Hi @ricardoruivo 

 

We have deployed a fix that landed in Edge Canary and should be included in the next Dev update after current 80.0.320.5 build. This fix was also patched for current Edge Beta.

 

You should no longer see the issue on next Dev update. To confirm the fix works for you, you could try your scenario on Edge Canary or Edge Beta if you like.

 

Let me know if you still run into any issue.

Thanks for reaching out,

Highlighted

@DavidD95 

 

just got This is Dev Build 80.0.334.2 and the problem is solved!

 

Many thanks, keep up the good work.