SCCM 2010 - Component Status (Type & Availability) - Unknown for all components

Occasional Contributor

Hi all

Following a server restart I have an issue whereby all my components are displaying as availability unknown.  I have tried a reboot of the server and this has made no difference, even after waiting.
compmon.log & compsumm.log don't offer any insights and my google fu has been exhausted.

If I right click on a component and look at the messages, they are all present and as I'd expect.

If anyone has dealt with this before, and can offer any insights, I'd be most grateful. 


Server 2012R2, Single primary site, SQL on same box. hosted on vmware.


Status Summarisers.png

1 Reply
best response confirmed by Andy Kinseley (Occasional Contributor)
So I finally got to the bottom of this, and thought i'd write about it in case it helps anyone else in the future.
It all relates to one of my site components not communicating correctly following a network upgrade.

As well as the components showing as unavailable, other issues started to present themselves.
Site backup was failing due to VSS writer timeout, and packages were not distributing to one of my DP's which was also a State Migration Point.
To get the backups to succeed i had to restart the VSS writer service & manually kick off the backup. This would then try to stop the sitecomp process, but couldnt so i killed it manually, then also the same for smsexec process. After this the backup would go through and complete normally. Console would then show all components green but Type and Availability as Unknow.

This had me thinking that a component was holding up the sitecomp or smsexec process for some reason, so i started to look at the DP where the packages were failing. Errors in the logs stated that the site server did not have permissions to write to the location.
Pinging the server worked.
Mapping the ADMIN$ share worked.
However, when i tried to list the folders on any drive attached to the DP, the process would hang and eventually explorer.exe would crash out. I tested connecting to ADMIN$ on client workstations in the same office and experienced the same issue.

At this point i summonsed our network engineer. who did the following:
(to quote)
I added "ip tcp adjust-mss 1300" to the data VLAN SVI on the remote site router. I think it brings down the maximum segment size for TCP syn packets from the standard 1500 to 1300.

As soon as this change was made, i was able to list folders in ADMIN$ on the DP, content started to transfer, components cam back showing availability, and my backups work again.