Add Operating System Upgrade Package error with CM 2006

New Contributor

I'm running into an issue when attempting to create an Operating System Upgrade Package using the Add Operating System Upgrade Package Wizard. The wizard fails with the following error:

 

• Description = "Failed to rename the file due to error 5";
• ErrorCode = 5;
• File = "..\\sspbootimagepackage.cpp";
• Line = 4941;
• ObjectInfo = "CSspBootImagePackage::ConvertToSingleIndexImage";
• Operation = "ExecMethod";
• ParameterInfo = "SMS_BootImagePackage";
• ProviderName = "WinMgmt";
• StatusCode = 2147749889;

dpsmith336_1-1612465660667.png

 

Since "ErrorCode = 5" corresponds with Access Denied, I have reviewed both NTFS and share permissions for the path containing the operating system files, even going as far as granting Everyone Full Control on both NTFS and share permissions and I continue to receive the error.

 

SMSProv.log indicates a failure to overwrite install.wim with the extracted WIM that DISM creates as part of the wizard as shown below:

 

  • Failed to move the file \\MECMServer\OS_Images\Upgrades\sources\{B0959BD1-16BF-4221-A6DB-826244208136}.wim to \\MECMServer\OS_Images\Upgrades\sources\install.wim due to error 5.
  • *~*~..\sspbootimagepackage.cpp(4941) : Failed to rename the file due to error 5~*~*
  • *~*~Failed to rename the file due to error 5 ~*~*

dpsmith336_2-1612466533087.png

 

A Procmon capture indicates Access Denied with the following, even though DISM can successfully extract the specified index from the WIM file and write back to the path containing the source WIM file:

dpsmith336_0-1612473058222.png

 

The DISM command that the wizard executes is below:

  • '"C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\DISM\dism.exe" /Export-Image /SourceImageFile:"\\MECMServer\OS_Images\Upgrades\sources\install.wim" /SourceIndex:3 /DestinationImageFile:"\\MECMServer\OS_Images\Upgrades\sources\{B0959BD1-16BF-4221-A6DB-826244208136}.wim"'

I suspect that the overwriting of install.wim fails because DISM hasn't released its hold on install.wim before the overwrite is attempted.

 

Any help will be greatly appreciated. Thank you.

4 Replies

@dpsmith336 
Sorry for this cheap answer, but have you tried rebooting the CM Server that is throwing the error?
I an into this once in the past, it was after applying patches to the server and I hadn't rebooted the server yet.

 

I restarted the CM server and the CM databases server today for kicks and grins but I continue to experience this issue when running the Add Operating System Upgrade Package wizard. Thanks for the suggestion though.

@dpsmith336 

Couple other generic things:

  • Make sure you're on the latest ADK
  • Try downloading the Windows Media from MS Volume Site again, and try with a cleanly downloaded version
  • Make sure you're a local admin on the machine that is running the DISM command
  • Try a different file share, make one on your workstation, and open it to everyone, and try importing from there (Not saying leave it there, but might help figure out if it's an issue reading / writing to the current file server)

 

I already have the latest ADK and membership in the local Administrators group. I downloaded the latest Win10 20H2 ISO from VLSC to another server, extracted and shared it and the wizard worked perfectly. So I created another share on the original server I was having issues with, copied the contents of the recently extracted ISO to the share, attempted the wizard and it again worked perfectly. The new share has the same share and NTFS permissions and is located on the same volume as the original share I was using. Very weird. The only thing that's different is originally, the contents of the ISO were located in a subdirectory of the original share. Now, the contents of the ISO are located in the root of the new share. I don't understand why that would have anything to do with it but it works now so I'll take it. Or maybe it was a fresh download from VLSC. Either way, thank you for your suggestions.