Intermittent Error "Keyset does not exist"

%3CLINGO-SUB%20id%3D%22lingo-sub-2532140%22%20slang%3D%22en-US%22%3EIntermittent%20Error%20%22Keyset%26nbsp%3Bdoes%26nbsp%3Bnot%26nbsp%3Bexist%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2532140%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3C%2FP%3E%0A%3CP%3EWe%20are%20getting%20an%20error%20%22%3CSPAN%3EKeyset%26nbsp%3Bdoes%26nbsp%3Bnot%26nbsp%3Bexist%3C%2FSPAN%3E%22%20(%3CSPAN%3E%22source%22%3C%2FSPAN%3E%3CSPAN%3E%3A%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3E%22System.Security.Cryptography.Csp%22%3C%2FSPAN%3E)%20randomly%20in%20Azure%20Functions%20with%20MSAL%20library%20while%20accessing%20OAuth%20token%20using%20certificate-based%20authentication.%20The%20error%20is%20intermittent.%20We%20couldn't%20identify%20the%20root%20cause%20and%20looking%20for%20a%20permanent%20fix%20to%20this%20issue.%20Can%20anyone%20help%2C%20please%3F%20Attached%20screenshot%20of%20the%20code.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2532140%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDeveloper%20Tools%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESecurity%20%26amp%3B%20Compliance%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Microsoft

Hi All,

We are getting an error "Keyset does not exist" ("source""System.Security.Cryptography.Csp") randomly in Azure Functions with MSAL library while accessing OAuth token using certificate-based authentication. The error is intermittent. We couldn't identify the root cause and looking for a permanent fix to this issue. Can anyone help, please? Attached screenshot of the code.

0 Replies