Cannot select existing Availability Set when creating a new VM

Occasional Contributor


I have an MSDN subscription and am starting to learn Azure


from I create the following items in no particular order


1) Virtual Network

2) Public IP Address

3) Storage Group

4) Load Balancer (which I associated with the Public IP Address)

5) Availability Set


I understand if I want to NAT Public facing IP address/port to my VM in Azure I need to setup a Load Balancer/Public IP address and place the new VM (created last) into an Availability Set (although I still not sure why I need to use an Availability set when I want to use NAT rules).


Any how, I then went on to create a VM (Windows 2012 R2 data centre) but it did not show my existing Availability Set (it just gave me the choice of creating a new one), but my availability set it there and ready.


Is this a bug in Azure or am I doing something wrong?

also, do I really need an Availabily Set (apart from the obvious static public IP and load balancer) ir order to ultimately setup my own NAT rules?


Please advise







6 Replies

The availability set has to be in the same Resource group as the VM's you are trying to deploy.



That said, you do not need to create an availability set for Port forwarding in Resource manager.

BUT the availability set allows Azure to know these 2 machines cover a vital role, and they should not take them both offline at the same time.
The load balancer can attach single machines or a entire Availability sets to make management easier.

any machine added to an availability set marked as a backend pool will automatically partake in recieving the traffic


Hello Kent

Thanks for taking the time to reply to my question.


I wonder if I am experiancing somesort of bug but I get the same result in Windows Edge Brower and Internet Explorer


I am using Windows 10 version 10.0.14393 and build 14393


I have one Resource Group and all my other resources are part of this Resource Group (based in West UK)


I left it 24 hours but when I go to create a VM it does not show my existing Availability Group is being available (it does not show it at all) and therefore I have the option of None or to create a New one.


Also I notice when I am on my Azure Portal home page under the 'All Resources' & ' All Subscriptions' tile it does not show my ResourceGroup (but it does show the other items). However if I click on ResourceGroups on the leaf most menu/tile it does show my ResourceGroup.


Therefore I now have two issues the main one being I cannot select a current AvailabilityGroup when building my first VM and also I do not see my Resource Group under 'All Resources'


Any idea, what is going on here please? can Microsoft offer an explanation?





best response confirmed by AUser ZUser (Occasional Contributor)

The lack of seeing resource groups from the "all resources" is by design.

Resource groups are just logical containers, so the serve no purpose in that view.


With regards to you availability set, try and create a new one prior to clicking create copy the Resource template so i can see what you would have created.


You may have chosen to create a classic Availability set, it gives you classic or aligned "in reality its classic vs. ARM"


Hello Kent,


Thanks again for taking the time out of your day to reply.


Thanks for clearing up the point with regard to Resource Groups and the 'All Resources' view.


With regard to the Availability Set I may of inadvertently created a classic one (not sure) I have deleted now, but the next time I create one I will make sure I used managed


All my questions answered in this post now.




It might be down to the portal layout. If your VM's are not using managed disks, and you've therefore created the availability set for non-managed disks, then when you come in to add your second VM you need to first change the 'Storage - Use managed disks' option to No BEFORE you go in to the Availability set picker.


If not, it'll only show the Availability Sets which are set to use Managed Disks, since that's the default option on the VM Settings blade. Very confusing since it looks like your Availability Set has just vanished.


If they positioned the Storage section before the High Availability section this wouldn't be an issue.

Today i faced the same issue. 


I'd to restore a VM, within it's old Availability set. 

I tried for 4-5 hours investigating and troubleshooting. Even tried scripts to change the availability set. 

Tried Disk Swap but worked nothing. 


At last, I found little odd within the "Availability set" >>"overview" section I found the option "Managed" was set to "No". 


So I upgraded that to "yes" via option "convert to managed"


and that's it. I resolved the issue. 


hope that works for you guys.