Cannot access new vm via public ip address

Copper Contributor


I am new to Azure.  I have created a new vm, which i am able to access via rdp and have setup iis, which is accessialbe via the internal ip address.


I have setup a load balancer and virtual public address.  I have inserted the public ip address on our web hosting providers portal.


The problem i have is i cant access the public ip address and therefore cant see the iis.  The error message say "The site cant be reached".

Any help would be much appricated.


10 Replies

I seem to have the same issue.

best response confirmed by JuniorAburto (Microsoft)



I was finally able to have success by creating an inbound rule to allow incoming traffic on port 80.


Under the Azure Dashboard, I clicked on the VM entry, then under its options I scrolled down to Networking. There I created a new inbound rule, for port 80, with a priority of 100, and the VM was finally viewable on the public IP address.

I did same and issue still there @Doug Joseph 

I followed the same approach and now I can access my public ip , thanks for the help

I had the same problem with port 80 open. 
I managed to solve it by getting a root session using terminal and reboot the VM, that was it. public ip is accessible. 

@Doug Joseph Thanks! this worked for me too

You need to install the IIS on the VM's and then set the priority for port 80; you should be able to access the VM's through public IP

goto server management first remove iis and net frame work 3.5 and 4.7 and restart vm then install iis and next in feature select net frame work 3.5 and 4.7 all three option and next select all options i mean check all box then install after installation done restart the vm go to internet explore type in address bar localhost  there you will see iis page successful   @pg_05 

@Mohammad Ahmad 


Same problem, but I followed all steps ( I use free tier with free assets)

worked for me 2022 thanks friend