WVD Load Balancing Question

%3CLINGO-SUB%20id%3D%22lingo-sub-1254190%22%20slang%3D%22en-US%22%3EWVD%20Load%20Balancing%20Question%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1254190%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20deployed%20what%20would%20be%20our%20small%20production%20shared%20desktop%20VMS.%26nbsp%3B%20There%20are%20three%20(-0%2C%20-1%2C%20-2).%26nbsp%3B%20We%20created%20an%20image%20from%20our%20dev%20deployment%20and%20deployed%20to%20our%20prod%20with%20some%20minor%20issues.%26nbsp%3B%20After%20that%20was%20resolved%2C%20we%20now%20see%20all%203%20hosts%20ready%20to%20take%20connections.%26nbsp%3B%20However%2C%20we%20see%20that%20only%20-0%20and%20-2%20are%20taking%20connections%20and%20-1%20is%20sitting%20there%20lonely.%26nbsp%3B%20I%20probably%20have%20to%20increase%20our%20test%20group%20but%20what%20should%20the%20load%20balancing%20behavior%20be%3F%26nbsp%3B%20We%20are%20set%20to%20%22Breadth-First%22%20so%20I%20would%20suspect%20that%203%20sessions%20be%20load%20balanced%20across%203%20servers.%26nbsp%3B%20Instead%20we%20we%20see%202%20on%20one%2C%201%20on%20the%20another%2C%20and%20then%20one%20just%20sitting%20there%20empty.%26nbsp%3B%20All%203%20are%20set%20to%20allow%20new%20sessions.%26nbsp%3B%20Is%20this%20normal%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1278614%22%20slang%3D%22en-US%22%3ERe%3A%20WVD%20Load%20Balancing%20Question%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1278614%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F279502%22%20target%3D%22_blank%22%3E%40stevenzelenko%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ebreadt-first%20load%20balancing%20all%20users%20over%20all%20hosts.%3C%2FP%3E%3CP%3Ewhe%20you%20have%20three%20host%20and%20login%20with%20three%20diffrent%20users%20than%20all%20users%20should%20be%20on%20one%20host.%3C%2FP%3E%3CP%3Ealso%20your%20rdp%20connections%20to%20the%20host%20will%20be%20counted.%20I%20mean%20when%20you%20are%20logged%20in%20to%20one%20host%20via%20mstsc.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

We have deployed what would be our small production shared desktop VMS.  There are three (-0, -1, -2).  We created an image from our dev deployment and deployed to our prod with some minor issues.  After that was resolved, we now see all 3 hosts ready to take connections.  However, we see that only -0 and -2 are taking connections and -1 is sitting there lonely.  I probably have to increase our test group but what should the load balancing behavior be?  We are set to "Breadth-First" so I would suspect that 3 sessions be load balanced across 3 servers.  Instead we we see 2 on one, 1 on the another, and then one just sitting there empty.  All 3 are set to allow new sessions.  Is this normal?

1 Reply

@stevenzelenko 

breadt-first load balancing all users over all hosts.

whe you have three host and login with three diffrent users than all users should be on one host.

also your rdp connections to the host will be counted. I mean when you are logged in to one host via mstsc.