WVD Classic Cleanup

Contributor

I played with WVD Classic previously, and now use WVD ARM. I thought I cleaned up all the classic bits, but one is still showing it's face when we plug in the feed into the Remote Desktop app, as it still shows up as a workspace with a single app (the original full desktop app that is created by default).

 

I can't find it within Azure Resource Groups either, and since it's a Classic one it doesn't show up in the WVD arm blades.

 

Any idea how to get rid of this workspace from Classic? I've poked around using get-rds* type commands which I believe is how you interface with Classic, and haven't found anything.

9 Replies

Hi @Brian Martin , sounds like you are on the right track with get-rds* I would expect you should see something with Get-RdsAppGroup. Are you authenticating to the rd broker before running the command?

@Jensheerin 

 

I open up my session with "Add-RdsAccount -DeploymentUrl "https://rdbroker.wvd.microsoft.com"" if that's what you mean.

 

Get-Rdshostpool comes back empty/no-results. Getting hostpool and/or appgroups all require specifying a hostpool to complete the command, which there is no Hostpool. There IS a tenant group though, but no Tenant per the relevant powershell queries. It's like that workspace/remoteapp is orphaned. 

 

I'm stumped.

Hi @Brian Martin,
Sorry for the delay in replying.

Maybe you have more than one. Try using the Get-RdsTenant - name with a ForEach-Object and the same for Get-RdsHostPool and Get-RdsAppGroup to see if you find it.

Once found you can use Remove-Rds* to detete.
It isn't there. I opened a case with MS and they also were stumped and digging behind the scenes now and will get back to me.

@Brian Martin Did you ever get this resolved with MS? Thought I'd check before logging a call as I have the same issue.  Tenants, Hostpools etc long deleted but still showing up in my feed.

 

Thanks
Tony

I had tried that KB before, but could see no resources once logged in.  However this time it jogged my memory that another account was used to create the Tennant and when I connected with it, I could see the resources and have been able to now delete them manually.  Thanks all!

Issue is not resolved. @Jensheerin

 

The steps in the article are things I tried with MS support. The challenge is the resource group is already gone. There is no way to reference the pool in question. MS support did not get a solution now that I think about it. The resources were created with my account so the way the other person said it fixed theirs doesn't help me.