Windows Remote Desktop Client bug - "failed to subscribe since there is no workspace"

Copper Contributor

We have had a couple of users connecting to RemoteApps fine using the Windows Remote Desktop Client. It started throwing errors saying cannot refresh so we tried unsubscribing and resubscribing and this is where the fun starts:


Click subscribe > an immediate error pops up "We failed to subscribe since there is no Workspace at



Note that the url (I believe) is the non ARM classic URL. We have never deployed using this.


The problem persists even when we clear personal data (from the about tab) and uninstall and reinstall.


If we click Subscribe with url > does not recognise the email address (even though we have email discovery turned on and the user accounts are fine as they worked yesterday). Add in the ARM subscribe URL and it is not recognised, the Confirm button is not enabled so we can do nothing.


Clearly some strange bug with the client.


Any ideas how I can get round  this?

14 Replies
are you still hitting this problem? if you do, can you please file a feedback with feedbackhub? please use Category Apps/Remote Desktop. Please share the link to your feedback.

Were you ever able to resolve this issue? I have the same thing happening on several windows embedded thin clients.


@James Bliss 

@clang318 Afraid not. We never found a resolution to this.

We have just encountered the same issue at one of our clients. Lots of users working on and the occasional user with the issue. Microsoft??
Do you see the same issue with Html5, Windows Store remote desktop client?
Please file a feedback hub feedback with category Apps/Remote Desktop. Please share the link to your feedback after you file it. The feedback hub feedback will give us a bit more info to start investigate.

@Soo Kuan Teo  can you provide a URL or instructions to "file a feedback hub feedback with category Apps/Remote Desktop"  I' don't know what you are talking about.  



Make sure to do this from the client device where the user ran into issue. Alternatively, can you send the UPN of the user with this issue and a UTC timestamp (if repro no longer happens, otherwise, UPN should suffice).

You can access feedback hub in 2 ways, on the machine that has the repro:
1. Click on the 'Feedback' link at the top right of Windows Remote Desktop Client UI, next to the 'smiley face' icon
2. click on windows start menu, type feedback hub, it will get you to the feedback hub UI.

best response confirmed by Eva Seydl (Microsoft)

actually, what @Soo Kuan Teo suggests in #1 is the best option

Did anyone get a resolution on this one?

Unfortunately, I also have same issues.

I use Notebook which using Windows 7 Pro 64 bit. I3 2Ghz, RAM 4 Gb.

do need to resolve this problem.

@James Bliss 


Reset Internet Explorer - Check the Delete Personal Settings box and reboot the PC. 

For the future help, I think the solutions in this post is workable. Maybe those who encounter the issue now can try them.

@James Bliss Hi. We also ran into this issue on HP Thinclients with Windows 8.1 embedded. Did you manage to get it to work in the meantime? we are also curious for a solution as we have not found it yet.