Windows 11 Multisession AVD - problem upgrade to 22H2

Occasional Contributor

Hello, I have a problem updating the VM used for my Azure Virtual Desktops; When I update I get the following error:

The VM generator is 2.0

 

Screenshot 2022-11-16 alle 12.44.39.pngScreenshot 2022-11-16 alle 12.45.13.png

5 Replies

I hope you had enabled TPM on your virtual machine? If not, please make sure its enabled as TPM 2.0 is a requirement for the Windows 11 Upgrade.

askaresh_0-1668666162777.png

 

@askaresh 

I tried to activate it by running the following commands

az vm update \
--resource-group  \
--name  \
--enable-secure-boot true \
--enable-vtpm true

 

but I get the following error back

 

(PropertyChangeNotAllowed) Changing property 'securityProfile.uefiSettings' is not allowed.
Code: PropertyChangeNotAllowed
Message: Changing property 'securityProfile.uefiSettings' is not allowed.
Target: securityProfile.uefiSettings

 

 

 

Screenshot 2022-11-17 alle 08.53.50.png

Make sure the virtual machine is Gen2 and last when i checked there were some limitations on Multi Session (Feature was under preview)

https://learn.microsoft.com/en-us/azure/virtual-machines/generation-2 (jump to the FAQ)

@askaresh 

The VM is Standard D2s v3 (2 vcpus, 8 GiB memory)

 

@micheleariis Found this on the doco you cannot enable trusted launch on an existing virtual machine

 

askaresh_0-1668731330405.png

 

As a test deployed Standard D2s v3 and tried changing in the UI no option under Configurations and with PowerShell it gave an error.

 

askaresh_1-1668731387788.png