Unavailable Session Host After Deployment

Copper Contributor

Hi everyone,

I've been experimenting with Azure Virtual Desktop and have followed the step-by-step guide here:


At first, the deployment worked perfectly: following this guide resulted in a working Windows 11 VM. Trouble was, I could only connect to it using the local admin credentials, not using my Azure AD details - I'm using a non-domain joined device and have followed the instructions to add the various options to the RDP Properties.

So, I thought maybe I'd made a mistake in following the instructions in setting up the , or Host Pool. So, I removed everything, deleted the VM and cleared it down (except the network).

I re-created everything as per the instructions and now, any time I create a new session host, it deploys successfully but remains "unavailable" in the host pool:


I can connect to it via the serial console under VMs and can show it's running. 

Things I have already tried:

  • Restarting the RDAgentBootLoader service (per this article) via the serial console
  • Restarted the VM
  • Waited several hours in case it came back
  • Deleted the VM and created a new session host with a different Windows build

The VM appears to be running perfectly, but the connection between the VM and the Host Pool seems to be broken. The VM is in EntraID rather than Active Directory, if it makes any difference.

Any suggestions are very welcome. I've probably done something daft.



4 Replies

@StephanF135 login to the vm as local admin and check the event logs. There should be something indicating why.

If you're encountering an "Unavailable Session Host After Deployment" issue, it could indicate a variety of potential problems. Common causes may include network configuration issues, insufficient resources on the host machine, or errors during the deployment process. To resolve this, check your network settings, ensure that the host machine meets the necessary requirements, and review deployment logs for any errors. Additionally, consider reaching out to technical support or consulting relevant documentation for further assistance tailored to your specific deployment environment.



Would suggest to retrieve logs to tell you the story

Open Event Viewer and go to Windows and check Application logs.