Unable to connect with Microsoft Remote Desktop apps (RDP)

Copper Contributor

Good morning,

yesterday we've noticed that Microsoft Remote Desktop app yields an error when trying to access an RDP server using a user account with an expired password or with the AD flag to change the password at first login set to true. It happens with different versions of the Remote Desktop app and with NLA (Network Level Authentication) disabled.


I have tried different versions of Remote Desktop:

- Microsoft Remote Desktop for macOS v10.8.1

- Remote Desktop for Windows v10.2.3000.0 from Microsoft Store

- Remote Desktop Connection v21h1 on Windows 10

- Remote Desktop Connection v21h1 on Windows 11

- Remote Desktop for Android v10.0.15.1208

- Remote Desktop for Android v8.1.81.435 


We tried to connect to different Windows Server OS versions and we always get the alert "Need change password", without giving us the possibility to change it. 


Schermata 2023-01-27 alle 15.43.14.png


Interestingly, the macOS and Android 10 versions of the app are the only ones that produce the following error when targeting a Windows Server 2008 R2 machine: 


Schermata 2023-01-27 alle 13.09.57.png

A few months ago, everything was working properly and we did not change anything on the target servers, neither at the GPO or setting level.

Any suggestions?



2 Replies



RDP users are NOT able to change their passwords upon first log in or after password expiration if their AD accounts have the “User must change password at next logon” option enabled as shown below.




I can swear I did it many times.
Is this a new change? Is it documented somewhere?