The task you are trying to do can’t be completed because Remote Desktop Services is currently busy

Copper Contributor

We have a WVD deployment and we have faced some issues with WVD, here you have the list of our current pain points:


  1. Users are getting this error messages while trying to access WVD through the Remote Desktop App or through the Web
    • The error message: “The task you are trying to do can’t be completed because Remote Desktop Services is currently busy” while connecting to the WVD pool”
    • The error message: “Oops, we couldn’t connect to  “MyPC-E3” we could not connect to the gateway because of an error” while connecting to the WVD pool”
    • The error message: “We couldn’t connect to the Remote Desktop Gateway because of an orchestration error”

To add a little bit more on this, we have found that every time that the users are getting these errors, some of the WVD hosts in an RDP session with the local administrator account are showing a black screen and the only way to fix it is by restarting the PC.


Our current WVD host pool has 8 PCs,  4 are Windows 10 Enterprise version 1809 and 4 are Windows 10 Enterprise version 1903.


Feel free to ask any minor details that could be relevant for a solution.

10 Replies
best response confirmed by Eva Seydl (Microsoft)

@Daghoberto:Thank you for reaching out for those issues. I recommend to file a support request as those issues might have different root causes. Additional logs will help to pin down those issues.



What was the fix in your case? I have a different setup but I'm also receiving the same message periodically.

@Chris Parker  Yes, I was able to fix it by having a different svchost.exe process for each process.

The problem is bisrv (BrokerInfrastructure) is receiving a large number of events using threadpool threads and then it is sending a ALPC request (which again uses thread pool threads) to SystemEventBroker Service which is running in same SVCHost. This caused thread pool exhaustion. Since thread pool threads are exhausted, we can no longer process requests resulting in hang.


We do have a workaround for the issue, run SystemEventsBroker or BrokerInfrastructure service into its own host process.


Action Plan: Perform following on all WVD computers

  1. RDP into the computer with admin account -> Start Regedit
  2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SystemEventsBroker\ and change the value of the key “Type” to 16 (decimal) (or 0x10 hex)
  3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BrokerInfrastructure\ and change the value of the key “Type” to 16 (decimal) (or 0x10 hex)
  4. Reboot the machine
  5. Log into the VM again -> open command prompt as administrator and enter command tasklist /svc > c:\tasklist.txt
  6. Open tasklist.txt and verify SystemEventsBroker or BrokerInfrastructure are in own svchost


7. Monitor and let me know if the issue resurfaces

@Chris Parker 

Hi Chris,

How is this fix working out for you?

I've encountered similar issues for one user in our multi-session environment today and I can't reboot the machines just yet.

RDP'ing to the session hosts directly works but just cannot connect via the WVD client.

@Chris Parker 


Hi Chris, 


I've had the same issue today. Did this work for you?



not sure if you have a fixe yet, but i had a similar issue today on a windows 2016 server.  Some background as to what i think caused the issue. I was trying to RDP to a server, but both sessions were in use, so i left the screen open while checking with the guys if i could log either of them off, however, i got sidetracked and forgot about. Eventually, i recalled having a need to login, so i went back and instead of clicking "cancel" on the screen, i decided to "reconnect", so not cancelling my login attempt.  all subsequent RDP requests resulted in the message " the task you are trying to do can be competed .. "



So to the simple fix for my issue.


ran quinsta /server:servername to see for any sesions .. 

i saw "session 4" which had no session name or username but had a session ID, 




used tasklist /s servername to view the tasks, but used a filter


tasklist /s "servername"/fi "session eq 4"




Then, i killed the LogonUI.exe , using the PID with Taskkill


taskkill /s servername /PID 4692


I tried kill winlogon, but that was not allowed.


hope this works for someone else who is unable to reboot the machine to fix it .




I do still get it from time time. I'll give this a go next time thank you!

@Daghoberto Hi, are you still meeting with the issue? You can reset stuck client Remote Desktop session. 

Step 1. Press Win + R, then type in “cmd” and press OK to open up the Command Prompt window.  

Step 2. Open a command prompt and type in “query session”. Then the command prompt returns a session name and ID for the affected user. In this case, we will assume “system” is having the issue. Take note of the user’s session ID, in this case it is Session 2.

Step 3. Type in “query process /id 2” in the command prompt. Then there will display the list of running process in the session ID you noted earlier. Find the csrss.exe process and its PID. In my case, the PID is 5140. You need to end this process.

 Step 4. Press Ctrl + Shift + Esc to open the Task Manager. Go to the Details tab and find the PID and the process we mentioned in the last step. Right-click it and then click End task.

Or you can see this post