Teams meeting button missing in Outlook

Copper Contributor

Hey all


After installing Teams on my Session host (w10 multi-session) it seems like Teams Meeting button is missing from Outlook.


I researched this issue and it appears to be some regedit keys that's necessary for this behavior.

I have uploaded a picture of my


Which is set to 3 but i still don't have the teams meeting button in Outlook.


I noticed that under "add-ins" in Outlook, i have a section called "inactive addins" and Microsoft Teams Meeting Add-in for Microsoft Office is appears there. I have tried turning it on, which makes the button appear. BUT!, after i myself or my users restart Outlook. It disappears again...


I installed Teams via per-machine via Powershell 'ALLUSER=1'


Can anyone please, help me with this issue?

7 Replies



Hi there.

I`ve experienced this with some users in our organization , If I remember correctly I simply made sure all updates in Windows and Office were on the latest version , after restarted it normally came back and stayed there with no further problems
I attached a snippet of my Teams reg and its the same as yours , i included the AddinsData just in case yours differs and it makes a difference if changed.

Worst case i uninstalled / reinstalled Teams when I found it couldn't be updated and a fresh install fixed it again.
Hope this helps. 


@jacobus liebenberg 


This issue is on WVD (Virtual Desktop) where i have a session host (windows 10 multi-session)

However, i have already tried uninstalling it and install it again. :\ 


Office package is pre built Microsoft 365 ProPlus. 

However, i can double check if automatic updates is turned on...



100% , When i`m at work tomorrow i`ll double check our setup on our VM`s and come back to you in case your have not found a solution yet.
Not sure if it makes a difference or if its the same , but i normally had some issues with Office preinstalled on our computers and i uninstalled it and used the click to run installation from the office portal , a bit more time consuming but when we ship it out to some of our sites that dont have Onprem AD and is still busy being migrated to Azure AD i wanted our users to be able to work so i made sure their office and teams worked before shipping it.
I`m still old school sometimes with our deployment methods.


Morning , i had a look this morning and cant find anything out of the ordinary.

Last thing i can recommend is have a look at your Teams Meeting policy.
I`ve attached examples of what it should look like if you are unfamiliar with the Teams Admin panel.


Hope you come right. 

Very thankful for your engagement@jacobus liebenberg


It's set to "Allow Outlook Addins"


Earlier my users worked locally on there PC, and then they had Office 365 installed via and then the button was there for everyone.


This issue is a "small" issue, but in this day and age where everyone is working remotely it's a a very common tool....


I will try to keep this thread updated if i find a solution to this, hopefully i do and then it can help others.

In this step-by-step tutorial, learn how to fix Teams Meeting Button Missing in Outlook

@SamirAbdouCloud   My tab disappeared as it was deactivated due to speed loading alerts. Reactivated the add-in again  and its now fine.