Teams in WVD does not show WVD Optimized

Brass Contributor
have followed the docs on deploying teams to enabled optimisation but it does not work.

Have uninstalled teams and reinstalled using the msiexec command. Have logged out and back in. Have deleted app data locations and have cleaned the registery. Have removed Office and reinstalled with Teams excluded. Have installed Web RTC msi and used repair.

Teams is on the correct version but it will not show WVD optimised.

It is bizarre.
9 Replies

Hey @elliottchandler , 


First of all just double check that you have followed everything here -


So the key things are:

1) You have created the IsWVDEnvironment registry key

2) You are using the correct command line - msiexec /i c:\install\Teams_windows_x64.msi /l*v c:\install\Teams.log ALLUSERS=1 ALLUSER=1

3) WebRTC is installed 

4) Visual C++ is installed


Double check all that and let us know how you get on! 



@Neil McLoughlin 

I have followed the documentation you mention in addition to the Microsoft one on the subject.


I have tried variations of the uninstall and install of Teams with no success.



@Neil McLoughlin 


I am seeing the same issues with a new WVD build with the Windows 10 multisession 2004 + M365 App as well.  I even had an issue getting the Teams to install with the IsWVDEnvironment key created, so I had to create a Citrix key.  I also found out the WVD optimization broke after updating one of the windows 10 session host to 2004, and I had to remove/reinstall the WebRTC program to get it to work again.  There is still something weird with 2004 I think.

@Cookiekaikai @Neil McLoughlin 


I have just finished deploying a new WVD Pool and still the same issue. The Pool was built from a Golden Image that has Microsoft Office Pro Plus installed but without Teams. Followed the documentation again from Microsoft and still no sign of the WVD Optimised in the banner. This is so frustrating.


I have a support request open with Microsoft but I don't have a lot of confidence at the moment.

@elliottchandler @Cookiekaikai That is interesting, I have always used 1909. Will try it also on 2004 and report back. 

I am only using 1909 at the moment.

@Neil McLoughlin 

I think in my case I have found the issue. You must delete the %appdata%\local\Microsoft\Teams folder completely and the Identity Cache. Then when teams loads it prompts for sign in and then WV optimisation appears!

@elliottchandler Doh! Didn't think of that. Glad you have it fixed. Now you can experience the WVD Goodness that is Teams Optimisation! :)



You are a life saver!!!  Thank you for you input.


I actually had to delete %appdata%\Roaming\Microsoft\Teams folder to get it to work properly.