SOLVED

RemoteApps causing "local display monitors exceed allowed by remote host"

%3CLINGO-SUB%20id%3D%22lingo-sub-2310870%22%20slang%3D%22en-US%22%3ERemoteApps%20causing%20%22local%20display%20monitors%20exceed%20allowed%20by%20remote%20host%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2310870%22%20slang%3D%22en-US%22%3E%3CP%3EOriginally%20when%20I%20tried%20using%20Remote%20Apps%20everything%20worked%20as%20expected%2C%20however%20after%20about%20a%20day%20I%20now%20receive%20an%20error%20that%20local%20display%20monitors%20exceeds%20the%20limit%20allowed%20by%20the%20remote%20computer.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20maxing%20out%20the%20allowed%20monitors%20via%20GPO%20as%20well%20as%20registry%20with%20no%20change%20and%20I%20tried%20rebooting%20the%20VM%20with%20no%20success.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20had%20a%20similar%20issue%20and%20resolved%20it%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2310870%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Eremoteapps%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESupport%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2517255%22%20slang%3D%22en-US%22%3ERe%3A%20RemoteApps%20causing%20%22local%20display%20monitors%20exceed%20allowed%20by%20remote%20host%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2517255%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F281865%22%20target%3D%22_blank%22%3E%40mkilgore%3C%2FA%3E%26nbsp%3B%20were%20you%20able%20to%20resolve%20this%3F%20I%20have%20the%20same%20problem%20and%20want%20only%20one%20standard%20monitor.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Originally when I tried using Remote Apps everything worked as expected, however after about a day I now receive an error that local display monitors exceeds the limit allowed by the remote computer.

 

I tried maxing out the allowed monitors via GPO as well as registry with no change and I tried rebooting the VM with no success.

 

Has anyone had a similar issue and resolved it?

2 Replies

@mkilgore  were you able to resolve this? I have the same problem and want only one standard monitor.

best response confirmed by mkilgore (Occasional Contributor)
Solution

@BNofBN Yes, I ended up solving this by first making sure that multi-monitor mode was enabled in AVD, then I went into my Group Policies and found one that was limiting things to one monitor, I modified that policy to only apply to the machines that needed it (thus skipping AVD host) solving the issue.