"Remote Desktop licensing mode is not configured"

Contributor

We've deployed a WVD image and things are working well; though sometimes when we log in, a message displays saying "Remote Desktop Licensing Mode is not configured" -- and that Remote Desktop services will stop working in XX days. (Around 80 for one image)

 

We've followed the instructions here: https://docs.microsoft.com/en-us/azure/virtual-desktop/apply-windows-license

 

Why are we getting this error? Will we have issues in ~80 days?

5 Replies

Hi @Nicholas Semenkovich ,

 

Which OS Version of Windows 10 are you using?

 

The 1903 version should give you plenty of time. Microsoft has acknowledged this message, and a fix/update will be available before the "Grace period" is passed.

@michawets  We're using 1903, the standard image as part of the deployment tutorial.

 

We actually found this recent page: https://docs.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-vm-configuration#remote-licensin...

 

However, after setting the Remote Desktop licensing mode to "Per User", we now get this error that "No Remote Desktop license server is specified."

 

Screenshot 2019-09-24 at 2.07.15 PM.png

 

* bump * here; we're still seeing the warning "No Remote Desktop license server is specified." on our WVD endpoints when we sign in to the desktop -- one has about 70 days remaining.

 

Is anyone else seeing this?

 

Screenshot 2019-10-03 at 12.42.51 PM.png

We have this on our deployment, but says circa 580 days until it'll stop working. Where did you get the image?@Nicholas Semenkovich 

@Nicholas Semenkovich We have this issue as well, and now the days are passed. So when a user is signed in they receive a message that they will be signed out after 60 minutes due to licensing issues.