OneDrive in AVD

Occasional Contributor

We've been running AVD for almost a year now in production.  Recently, users started to report this error with OneDrive when they try to launch a file for the first time.

CaptainReboot_0-1646766836546.png

If they click on try again, it works.  We have OneDrive setup so that it does not cache any files from OneDrive, files are only available on demand.  Once they sign off, everything gets removed from cache. We are using version 20.033.0213.0002 installed with the /allusers switch.

 

Anybody run into this before?

16 Replies

@CaptainReboot 

We have similar problem(0x8007017c). I have this problem on almost production environment, just before switching to production.

I make a test with clean VM(azure) with win 10 multi session 21h2, fslogix in latest version, onedrive too(and citrix VDA). We using odfc and profile container and moved known folders to onedrive. I suspected defender ATP, but after offboarding problem persist. I tried onedrive 21.230.1107.0004 with no luck. I try to make new VM without win updates...

I have the exact same issue, but in our Citrix environment. Did you find a solution to this?

MS finally realize and accepted that this is error. I have premiere support ticket and waiting for developers to make some fix, but we don't know when it will be. I will let you know, when fix will be online.
That would be great. Thank you!

@souky222 That would be awesome if you could let us know when/what the fix is. I haven't had much luck with Premier/Unified support tickets so I didn't even bother submitting one for this.

We have started running into this same error inside our Citrix Environment with FSlogix. We were on the deferred branch and OneDrive just rolled over to version 22.

One thing I have noticed is that the error only happens when the "File Attribute" is set to '5248545'. If you reset your OneDrive account manually, it will load in the offline files and they are initially set to '4199969' and those work fine.

Using the following:

attrib -p +u /s

This sets the file attribute to On Demand Cloud only '5248545' and pops the same error as the Original poster.

yes, setting attrib like this should be the same like clicking "free up space" in UI

This is fixed in the Insiders preview version 22.089.0426.0003

ok, I´ll wait when it will be in production ring. Thanks for info.
I can confirm that the issue is fixed in version 22.089.0426.0003. Thanks!
This is the insider preview for OneDrive?
Yes. I hope this will make it to production soon.
How do I get the insider version? I can't find much on it when I try to search for that version number.
Stephanstoke replied to Steve Downs
‎May 17 2022 02:02 AM

@Steve Downs @Vissersh @Sjaak null @souky222 @maximilianlinseisen @alexwilcox

Hi All!,

Just got a call from Microsoft that the OneDive files on demand error has been resolved.
Please make sure to install the latest OneDrive version: Version 2022 (Build 22.089.0426.0003) (64-bit)

Thanks and have a good day everyone!

Hey there

we are using OneDrive 2022 Build 22.121.0605.0002 x64.

The error consists .. 

You guys got any news from microsoft or equal?