Microphone not found in WVD (Teams and Skype)

Copper Contributor

we are facing an microphone redirect issue for our WVD Host pool. We are connecting to our WVD via the RemoteDesktop app client. In Teams and Skype the microphone is greyed out and not found. But the Audio is redirected and works.

We set up already following rdp property for the host pool: audiocapturemode:i:1

Still no mic. What can be the cause or fix to this. We really need to do Skype calls in WVD.

3 Replies

We are in same boat.  Have you opened a ticket with Microsoft support?  Where did you set the rdp property - in host pool group or the vm?



I solved the problem. Microphone and audio redirection now works in Azure WVD (Skype and Teams).


I done following to fix it:


1. Apply RDP properties on host pool level:


Set-RdsHostPool -TenantName <tenantname> -Name <hostpoolname> -CustomRdpProperty $properties


2. Reboot all Vms in the host pool.


3. Redirection only works with the RemoteDesktop app not over Webclient.


@Emre_Gurel I applied those same properties and still the mic is not detected.  Do you get same as pic below?