MacOS Remote Desktop App - Error Code 0x3000015

Copper Contributor

I deployed Windows Virtual Desktop in a test envrionment. Everything went smoothly and worked flawlessly. We've now decided to destroy the test environment and spin WVD up in a production environment. I did so by deleting the tenant and all associated resources/published apps in the test environment.


I've now created and deployed the production environment and everything is working except for the MacOS RDP client of a user who was part of the test environment. The feed and published apps pull correctly, but when I try to connect to any of the published apps I get Error Code 0x3000015.

Screen Shot 2019-09-03 at 1.38.24 PM.png

Any help is appreciated!

3 Replies

@shoopg any luck with a solution here? I had literally this exact problem: WVD works everywhere (web client, iOS client, etc.), except Mac OS X Remote Desktop 10 feed, where I registered a previous environment. Now, the old one doesn't work either:


Same issue here. RD Client on iPhone

Solution is that you need to select the right account in the workspace settings. if you selected your account thorugh authenticator the account settings is set to ask the account. after setting the right account it worked for me.