DSCextension failure

New Contributor

I have recently deleted the WVD tenant, hostpool, and tenantgroup in an attempt to recreate the VDI and have the machine go through a new Intune enrollment. The full error log I am getting is:

 

        "message": "VM has reported a failure when processing extension 'dscextension'. Error message: \"DSC Configuration 'FirstSessionHost' completed with error(s). Following are the first few: PowerShell DSC resource MSFT_ScriptResource  failed to execute Set-TargetResource functionality with error message: User is not authorized to query the management service.\nActivityId: 89eda1a1-dc5a-4abc-911b-897ab1abfd22\nPowershell commands to diagnose the failure:\nGet-RdsDiagnosticActivities -ActivityId 89eda1a1-dc5a-4abc-911b-897ab1abfd22\n  The SendConfigurationApply function did not succeed.\"."

 

 I have verified that my user and the service principal have RDS Owner in the tenant group, and that my user is a TenantCreator, but I still get this error. Unsure what else I may have missed in my recreation.

2 Replies

@dash-dj I am getting the same issue. I am using the same script which worked last week and I have tried to redeploy and failed. 

User is TenantCreator and MFA disable

I was actually able to figure out where my issue lied. The process of setting up the WVD does seem to be very process oriented. When I recreated it this morning I made sure that my service principal had RDS Owner app role before I created the host pool. That was the only change I made versus what I was doing before and I was able to get past this error.