Constant delay that makes WVD unusable

Not applicable

I have gone through all the steps to provision a host pool called Desktop. My tenant is Virtual Desktop and I have one session host called WVD-VM-0 which is a D4s_v3 instance.


If I RDP directly into WVD-VM-0 the performance is perfect and normal. However when using the Remote Desktop app or the web client I experience a constant delay of perhaps up to 500ms. Typing, moving windows, drawing in paint etc. is all significantly delayed. Either the encoding or there is input lag or constant networking lag.


The problem is not our network, we have a gigabit fiber link and I have tried from multiple other locations and this delay always occurs.


The connection quality always says 'Poor' in the Remote Desktop application, again it doesn't matter where I run it or on what type of internet connection.

This has been provisioned in the Australia East region. I have read that the control plane is currently in the US East 2 region. Does this mean the session is routed to that region and then back again? This would explain a 500ms delay in Australia. Any help would be gratefully appreciated. I want to use WVD for our small non-profit of 27 employees (even though it is still in preview) but the latency is too high to be usable.

2 Replies
best response confirmed by Eva Seydl (Microsoft)

 You are right. The WVD control plane is located in east us including the the rd gateways. All session traffic is routed through the rd gateways.


After GA of the WVD service rd gateways will be deployed in all azure locations and the session traffic is routed through this gateways.


You can try to mark your host pool as validation pool to get the most recent service updates:





@Claus Schwemmlein 


Thanks for the confirmation much appreciated.