Can't Provision Host Pools anymore

Brass Contributor

I have been able to successfully provision a host pool (with 2 hosts) once with published apps. Users can login.

I then provisioned another host pool with 2 hosts that would be used for Desktops.
I was able to login but when I tried starting a desktop I would get a username and password error.
To try and resolve this I cleaned the host pool setup by opening the Resource Group and deleting all the items within it.
However, now what happens is that the provisioning fails when provisioning the dcsextension starts.
The error says that the provisioning user does not have permission, which it does as it worked before but now no matter what I do I get this error and provisioning stops.

Has anyone else had this issue and if so how did you get around it?

4 Replies

@Paul Shadwell: Are you using a user account or service principal? If service principal please create a new one as we have seen issues with those that are older. 


Otherwise please confirm your issue is not named here:



@Eva Seydl I am trying with both username and service principal.
Thankyou for the link it looks useful.
Since the dscextension is the failure point and everything else worked it would be great to have a way to just re-run that part.

@Paul Shadwell : Just for clarity, the DSC extension is what:

- Creates the Windows Virtual Desktop host pool

- Installs components / registers the virtual machines to the host pool.


If the DSC was the only thing failing, (meaning the VMs got provisioned and were properly domain joined), I'd recommend:

1. Go to each of the VMs and remove the extensions

2. Follow the steps here to manually create the host pool and register the VMs:



Let me know if that helps!

@Christian_Montoya Thankyou for the responses.
Without changing anything I created a new host pool today with 3 hosts and it completed successfully in 22 minutes and 37 seconds.
Whatever was causing the issue before is now resolved.